Bug 1666205 - Helper message is not updated when default storage class is selected
Summary: Helper message is not updated when default storage class is selected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-15 08:23 UTC by Yadan Pei
Modified: 2019-06-04 10:42 UTC (History)
4 users (show)

Fixed In Version: 4.1.0
Doc Type: Bug Fix
Doc Text:
Cause: Imprecise wording on the helper message Consequence: Users might not understand why a specifc storage class was pre-selected Fix: Updated help message to be more clear Result: Clearer instructions to the user
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:02 UTC

Description Yadan Pei 2019-01-15 08:23:33 UTC
Description of problem:
When default storage class is selected, help message is not changed and not showing default storage class is selected

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-15-010905   True        False         11m       Cluster version is 4.0.0-0.nightly-2019-01-15-010905
$ sudo podman inspect <console_image_id>
            "version": "v4.0.0"
            "release": "0.139.0.0",
            "io.openshift.source-repo-commit": "a62eaa43f2aab9a817a3fb66e1c8b88d5ef100da",

How reproducible:
Always

Steps to Reproduce:
1. Create test storage class
$ cat storageclass.yaml
kind: StorageClass
apiVersion: storage.k8s.io/v1
metadata:
  name: slow
provisioner: kubernetes.io/aws-ebs
parameters:
  type: io1
  iopsPerGB: "10"
  fsType: ext4
$ oc create -f storageclass.yaml
2. Storage -> Persistent Volume Claims -> Create Persistent Volume Claim
3. Change storage class to slow -> then change back to default storage class

Actual results:
2. Default storage class is selected, but the helper message is still "Optional storage class for the new claim."
3. Although default storage class is selected, helper message is still "Optional storage class for the new claim."

Expected results:
2-3. When default storage class is selected, helper message should be updated "Default storage class <default_sc_name> will be used if no other storage class selected" per description
"Added default storage class handling. The default storage class is identified as "(default)" in the dropdown. Also, we update the help message"
in PR https://github.com/openshift/console/pull/812 

Additional info:

Comment 1 Zac Herman 2019-01-15 22:39:37 UTC
We did change this behavior but I forgot to update the PR.  However, the wording is not optimal so I will open a PR to change it to simply: "Storage class for the new claim."

Please keep this bug open and I will assign the fix here.

Thanks.

Comment 2 Zac Herman 2019-01-16 00:36:52 UTC
https://github.com/openshift/console/pull/1087 addresses this bug.

Comment 3 Yadan Pei 2019-01-16 08:12:01 UTC
Fix is not merged in v4.0.0-0.139.0.0, will check on next build

Comment 4 Yadan Pei 2019-01-17 03:11:06 UTC
Fix is not merged in v4.0.0-0.139.1

Comment 5 Yadan Pei 2019-01-21 03:30:34 UTC
Text is now changed to 'Storage class for the new claim.' 


Verified on 
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-18-115403   True        False         1h        Cluster version is 4.0.0-0.nightly-2019-01-18-115403

$ oc image info registry.svc.ci.openshift.org/ocp/4.0-art-latest-2019-01-18-115403@sha256:0c65f4d65acb6d7432637a33cdda6de8b23b5743706203f9fa58543530c26d21
             io.openshift.source-repo-commit=2dc8614b6f0975fe579a21b2e2cedf1f186af8e4
             io.openshift.source-repo-url=https://github.com/openshift/console

Comment 7 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.