Bug 1666223 - vxLANPort is redundant field in sdn-controller-config configmap
Summary: vxLANPort is redundant field in sdn-controller-config configmap
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.1.0
Hardware: All
OS: All
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Dan Winship
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-15 09:28 UTC by zhaozhanqi
Modified: 2019-06-04 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:02 UTC
Github openshift cluster-network-operator pull 142 'None' 'closed' 'Bug 1666223 - Remove temporary hack around vxlanPort serialization' 2019-11-20 11:08:17 UTC

Description zhaozhanqi 2019-01-15 09:28:08 UTC
Description of problem:
Check the sdn-controller-config config, there two similar field named: 


      vxLANPort: 4789
      vxlanPort: 4789


Version-Release number of selected component (if applicable):
quay.io/openshift-release-dev/ocp-release:4.0.0-0.1

How reproducible:
always

Steps to Reproduce:
1. check the sdn controller configmap
   oc get cm sdn-controller-config -n openshift-sdn -o yaml | grep -i vxlan
2.
3.

Actual results:

$ oc get cm sdn-controller-config -n openshift-sdn -o yaml | grep -i vxlan
      vxLANPort: 4789
      vxlanPort: 4789



Expected results:

vxLANPort: 4789 is redundant, should be deleted.


Additional info:

Comment 1 Weibin Liang 2019-01-15 18:51:31 UTC
Hi zhaozhanqi,

Which release you found this issue v3.11 or v4.0? I do not think it is v1.0.0 as you picked up for this bug

Comment 2 zhaozhanqi 2019-01-16 01:08:53 UTC
hi, Weibin

 should be typo, I choose to v4.0. thank you point this.

Comment 3 Casey Callendrello 2019-01-16 14:40:25 UTC
This was due to a migration; it will eventually go away.

Comment 5 Dan Winship 2019-04-17 12:34:01 UTC
Sorry, I thought this had already merged but it hasn't yet...

Comment 6 Dan Winship 2019-04-17 18:02:36 UTC
ok, merged now. since the errata doesn't actually have a build associated with it yet, I assume that this change will make it into whatever build does end up in that errata

Comment 7 zhaozhanqi 2019-04-19 01:26:03 UTC
Verified this bug on 4.1.0-0.nightly-2019-04-18-170154

Comment 9 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.