Bug 1666298 - anaconda fails to start due not enough free space in install.img
Summary: anaconda fails to start due not enough free space in install.img
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1666305 (view as bug list)
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2019-01-15 13:20 UTC by Dan Horák
Modified: 2019-01-17 16:22 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-01-17 16:10:17 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Fedora Pagure releng issue 8059 None None None 2019-01-15 15:44 UTC
IBM Linux Technology Center 174796 None None None 2019-01-21 16:39 UTC

Description Dan Horák 2019-01-15 13:20:29 UTC
Starting the installer fails on ppc64le because there is not enough free space in install.img filesystem. The compose's program.log says it's only 10MB (x86_64 reports 140MB free). The symptoms a "no space left on device" error.

df says 4K free on /dev/mapper/live-rw

tested with Fedora-Rawhide-20190115.n.0 (and previous)

The solution is to increase the install.img size to 3GB from the default 2GB. The main question is where it should be changed. In lorax directly or in the compose configs in pungi, globally or per arch. Maybe there is something we could remove in lorax in runtime-cleanup, but it would be a very temporary solution.

Comment 1 Vendula Poncova 2019-01-15 15:37:09 UTC
It looks like lorax should decide this. Reassigning.

Comment 2 Vendula Poncova 2019-01-15 15:38:23 UTC
*** Bug 1666305 has been marked as a duplicate of this bug. ***

Comment 3 Dan Horák 2019-01-15 15:43:22 UTC
I have also opened a rel-eng ticket https://pagure.io/releng/issue/8059 if we should go thru the pungi config route.

Comment 4 Dan Horák 2019-01-15 16:15:49 UTC
The created boot.iso is only cca 250KB bigger when the 3GB install.img is used compared to the 2GB one.

Comment 5 Dan Horák 2019-01-17 13:26:26 UTC
I've opened https://pagure.io/pungi-fedora/pull-request/684 to change the Fedora pungi config. I think it's better solution now as it is setting the new value for ppc64le only.

Comment 6 Brian Lane 2019-01-17 16:10:17 UTC
Thanks Dan, I'm going to close this for now. I agree that patching pungi is the better solution at this time.

Comment 7 Dan Horák 2019-01-17 16:22:38 UTC
ACK, Dennis Gilmore made a good point that having a bigger image by default could have negative effects on the low memory / 32-bit platforms, so better to go with pungi config change.


Note You need to log in before you can comment on or make changes to this bug.