Bug 166634 - MySQL not found when compiling PennMUSH 1.81
Summary: MySQL not found when compiling PennMUSH 1.81
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-24 03:00 UTC by Christoph Thompson
Modified: 2013-07-03 03:06 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-08-25 15:01:48 UTC


Attachments (Terms of Use)

Description Christoph Thompson 2005-08-24 03:00:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
When I gunzip and untar the source code and attempt to compile, it will state "You do not have mysql" when it attempts to locate the library files.  I have tried this multiple different ways, and it compiles fine on a Mandrake 10 box.  

mysqld is start, and a root password is set.

Version-Release number of selected component (if applicable):
Latest release of MySQL

How reproducible:
Always

Steps to Reproduce:
1. Download pennmush-1.8.1 from www.pennmush.org
2. gunzip the file
3. tar xvf the file
4. cd pennmush
5. ./Configure -d
  

Actual Results:  The source code compiles, but when you scroll back in the output you see - 
"You do not have mysql"

The system refuses to find the library files even though it is working.

Expected Results:  "You have mysql"

Additional info:

Comment 1 Tom Lane 2005-08-24 03:30:45 UTC
Offhand it sounds like you don't have the mysql-devel RPM installed?

Comment 2 Christoph Thompson 2005-08-24 03:38:07 UTC
You know, as odd as that sounds...you might be right.  On the initial install of
Fedora FC4 I did select /all/ the MySQL packages, including the devel package. 
But when I do 'rpm -q mysql' I get this - 

[root@ ~]# rpm -q mysql
mysql-4.1.12-2.FC4.1
[root@ ~]# 

Any suggestions on how to automatically download and install the development
package?

Comment 3 Tom Lane 2005-08-24 06:34:53 UTC
Well, it's been awhile since I installed Fedora from scratch, but I think there's a generic option along the 
lines of "install development support" that gets you the -devel RPMs for everything you install.

But the above rpm query proves little, because it will only show packages whose base name is exactly 
"mysql".  Try "rpm -qa | grep mysql"

Comment 4 Christoph Thompson 2005-08-25 00:15:39 UTC
Ok...ran that and this is what I got -

[root@wendy ~]# rpm -qa | grep mysql
libdbi-dbd-mysql-0.7.1-3
mod_auth_mysql-2.6.1-4
mysql-devel-4.1.11-2
mysqlclient10-3.23.58-6
mysql-4.1.11-2
php-mysql-5.0.4-10
mysql-server-4.1.11-2
mysql-bench-4.1.11-2
[root@wendy ~]# 

Seems the development package may be installed.  Any chance it might not be
installed to a "non standard" location?

Comment 5 Tom Lane 2005-08-25 15:01:48 UTC
Well, that's certainly a full set of mysql-4.1 RPMs.  Let's see [ digs through
pennmush Configure script... ]  It looks to me like the problem is that they
neglected to add -L/usr/lib/mysql in the test program's link flags.  You could
supply that yourself where Configure asks you about linker flags.  If you think
pennmush ought to know about this by default, you should take it up with them.


Note You need to log in before you can comment on or make changes to this bug.