Bug 166656 - ps2pdf screws up text - letters on top of each other
ps2pdf screws up text - letters on top of each other
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 09:39 EDT by Michael A. Peters
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 8.15-0.rc4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 11:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Resulting pdf file with error (76.09 KB, application/octet-stream)
2005-08-24 09:40 EDT, Michael A. Peters
no flags Details
The postscript file that generated the problem pdf (199.44 KB, application/octet-stream)
2005-08-24 09:41 EDT, Michael A. Peters
no flags Details

  None (edit)
Description Michael A. Peters 2005-08-24 09:39:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I have a latex document.
I can not use pdflatex etc. because it inputs gnuplot generated tex files (pslatex terminal) and colour does not show up in pdf unless I go the dvips route to first generate a postscript file, and then use ps2pdf

The postscript file is fine, but ps2pdf in one locations smashes one letter on top of another. I have viewed the resulting pdf in both evince and acroread, and printed the page, it occurs in all three tests. The ps file is fine.

Version-Release number of selected component (if applicable):
ghostscript-7.07-40

How reproducible:
Sometimes

Steps to Reproduce:
1. latex math_homework
2. dvips -Ppdf -o math_homework.ps math_homework
3. ps2pdf math_homework
  

Actual Results:  Most of the pdf is just fine, but at the bottom of page 15, the very last line, a 2 is on top of the unit vector it should be in front of. This does not happen (that I could see) anywhere else in the document.

Expected Results:  The pdf should look like the ps

Additional info:

I'll attach the postscript and the pdf file - the problem is at the bottom of page 15. The document is actually created in LyX - but I exported to LaTeX and that is where I generate the ps and pdf from. I looked at the LaTeX for where the problem occurs and it is fine.
Comment 1 Michael A. Peters 2005-08-24 09:40:26 EDT
Created attachment 118058 [details]
Resulting pdf file with error
Comment 2 Michael A. Peters 2005-08-24 09:41:42 EDT
Created attachment 118059 [details]
The postscript file that generated the problem pdf
Comment 3 R P Herrold 2005-08-24 10:26:37 EDT
I think this is a font file metics issue, actually, but I also see this often
with 'typewriter' stype fonts sets inside PDF's
Comment 4 Tim Waugh 2005-09-05 07:44:55 EDT
What version of urw-fonts do you have installed?
Comment 5 Michael A. Peters 2005-09-14 01:12:11 EDT
I keep my system up to date fairly regularly.
I don't know whether my URW fonts have been updated since then or not.

-=-
incidentally, I had gotten bad information from a website that stated I needed
to use the pslatex package in my LaTeX docunents to use the pslatex terminal
type in gnuplot, and that's not the case - name is the same, but pslatex is font
package in LaTeX - and since I stopped using it, the problem has not happened once.

It's still a bug since encoding with distiller matches the ps output in the
example I posted, but it isn't one that is biting me anymore.
Comment 6 Tim Waugh 2005-09-20 11:07:40 EDT
This seems to be fixed in ESP Ghostscript 8.15rc4 (ghostscript-8.15-0.rc4.3) in
rawhide.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.