Bug 1666585 - wrong repo link in the Package Server csv
Summary: wrong repo link in the Package Server csv
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: shahan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-16 06:05 UTC by shahan
Modified: 2019-06-04 10:42 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:01 UTC

Description shahan 2019-01-16 06:05:02 UTC
Description of problem:
wrong repo link in the Package Server csv

Version-Release number of selected component (if applicable):

$ oc adm release info registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-01-15-010905 --commits 
  operator-lifecycle-manager                                                                              54a541d82818a14eafa4af433d7360b4c65bbcce

  console                                                                                             f871de84d993327ecc723846bbac3959a36103c1
  console-operator                                                                                        fc525807811c77406c747398bd277f639f3e260a


How reproducible:
Always

Steps to Reproduce:
1. goto k8s/ns/openshift-operator-lifecycle-manager/clusterserviceversions/packageserver.v0.8.1 page, click Links: https://github.com/operator-framework/operator-lifecycle-manager/tree/master/pkg/packageserver

Actual results:
1. 404 not found 

Expected results:
repo link should be "https://github.com/operator-framework/operator-lifecycle-manager/tree/master/pkg/package-server"

Additional info:
$oc get cm olm-operators -o yaml -n openshift-operator-lifecycle-manager |grep 'links' -A2
- name: Package Server
  url: https://github.com/operator-framework/operator-lifecycle-manager/tree/master/pkg/packageserver

Comment 1 Jian Zhang 2019-01-16 06:17:30 UTC
The OLM version:
OLM version: 0.8.1
git commit: 54a541d
source commit: "io.openshift.source-repo-commit": "47482491fb29def1a3df05c3178b07de5761708f"

Comment 4 shahan 2019-03-25 08:13:44 UTC
The link is correct now. https://github.com/operator-framework/operator-lifecycle-manager/tree/master/pkg/package-server
cluster version: 4.0.0-0.nightly-2019-03-23-183709
Verified it.

Comment 6 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.