Bug 16666 - VIM named VI, breaks VIMTUTOR
VIM named VI, breaks VIMTUTOR
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
6.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-21 03:29 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 12:27:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-21 03:29:54 EDT
VIMTUTOR, a script listed in /bin/ after a Red Hat Linux 6.2 installation, 
fails to run because it makes use of VIM rather than VI to do its work. 
This results in the errors:

 /bin/vimtutor: vim: command not found
 /bin/vimtutor: vim: command not found
 rm: cannot remove `/tmp/tutor2333': No such file or directory

Users can resolve the problem with the following command while logged in 
as root:

 $ cp /bin/vi /bin/vim

The result of this is two copies of the exact same duplicate file: 'vi' 
and 'vim'.
Comment 1 Bernhard Rosenkraenzer 2000-08-21 05:36:00 EDT
vim is included in the vim-enhanced package.

The actual problem is with vimtutor, which should check which versions of vi are
there. This is fixed in rawhide.
Comment 2 Need Real Name 2000-08-21 12:27:42 EDT
"vi" in the full installation of RedHat 6.2 (a standard installation of the 
RedHat server) is actually vim.  Indeed, it would be nice if vimtutor detected 
vi/vim, but when one types "vi" (not "vim") he does not expect to see a 
big "VIM - Vi IMproved" screen, hence a possible flaw with the RedHat 
installation package.  Additionally, what is vimtutor doing included in an 
installation that doesn't install vim as "vim"?

vimtutor can be corrected by changing the script to use "vi" rather than "vim", 
but this is an incorrect solution because vi is not vim, and the vim tutor is 
specifically intended for vim; but then, the "vi" in RedHat is vim, so the real 
solution is for RedHat to rename vi to vim and to include the original vi.
Comment 3 Bernhard Rosenkraenzer 2000-08-21 13:06:34 EDT
Yes, on a Red HAt System vi == vim.
/bin/vi == vim-minimal == vim in vi-compatible, featureless mode
/usr/bin/vim == vim-enhanced == not-fully-vi-compatible version
with numerous features.

vimtutor can handle both, so the fix in rawhide (checking whether
/usr/bin/vim is there, and if it isn't, falling back to /bin/vi) is
the right one.
Comment 4 Need Real Name 2000-11-24 12:58:54 EST
Sorry, but why the hell isn't there any "vim" on RedHat?

I work a lot with different flavours of UNIX and I am used to type "vim" because
I don't want to use the old vi e.g. on Solaris systems.

So everytime I am logged onto a RedHat box i get annoyed by
"bash: vim: command not found"

Is it so hard to have a symlink from /usr/bin/vim -> /bin/vi ?

Most times I add this by hand, but it would be good to have it in the rpm.
Comment 5 Daniel Roesen 2000-11-24 13:40:09 EST
> Sorry, but why the hell isn't there any "vim" on RedHat?

There is. Install the vim-enhanced package as Bero explained.

Note You need to log in before you can comment on or make changes to this bug.