Bug 1666626 - Edit cluster-monitoring-config confimap to disable telemeterClient/enable ectd monitoring is not reasonable
Summary: Edit cluster-monitoring-config confimap to disable telemeterClient/enable ect...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Sergiusz Urbaniak
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1664862 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-16 08:48 UTC by Junqi Zhao
Modified: 2019-06-04 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:01 UTC

Description Junqi Zhao 2019-01-16 08:48:15 UTC
Description of problem:
Cloned from https://jira.coreos.com/browse/MON-515

For 4.0, any change in configmap would be rolled back, so edit cluster-monitoring-config confimap to disable telemeterClient/enable ectd monitoring is not reasonable

Although we have workaround to do so, it is not good for customers

for example: don't provide cloud.openshift.com in pull secret when build environment to disable telemeterClient, or setting objects unmanaged then edit configmap

 

Version-Release number of selected component (if applicable):
all 4.0 version

How reproducible:
Always

Steps to Reproduce:
1. Add the followings to cluster-monitoring-config configmap to disable telemeterClient

telemeterClient:
  enabled: false

2.
3.

Actual results:
a few seconds after adding these changes, the cluster-monitoring-config configmap rolled back, we can not change cluster-monitoring-config configmap

Expected results:


Additional info:

Comment 1 Frederic Branczyk 2019-01-23 15:42:53 UTC
This should be fixed now. The configmap is not created by default anymore, so it's not overwritten, the user just needs to create it themselves.

Comment 3 Junqi Zhao 2019-01-30 03:16:37 UTC
Could configure cluster-monitoring-config configmap now to disable telemeter or enable ectd monitoring

$ oc -n openshift-monitoring get cm cluster-monitoring-config -oyaml
cluster-monitoring-config -oyaml
apiVersion: v1
data:
config.yaml: |
telemeterClient:
enabled: false
etcd:
enabled: true
targets:
selector:
k8s-app: etcd
kind: ConfigMap
metadata:
creationTimestamp: 2019-01-30T01:18:58Z
name: cluster-monitoring-config
namespace: openshift-monitoring
resourceVersion: "798077"
selfLink: /api/v1/namespaces/openshift-monitoring/configmaps/cluster-monitoring-config
uid: 04b81fcb-242d-11e9-b566-06c77be1ac00


payload:
image: registry.svc.ci.openshift.org/ocp/release@sha256:aa2c0365957e6c7733fc3dfd21d9f06b95e7664b325620a19becfc5a665caf68


images:

cluster-monitoring-operator: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:03f03ef1202b0cd018bad3fbf21e2a3c4a2f30e23200cb61072441cb9e59a966
prometheus-node-exporter: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:0410b28aeaff7e091dcbdb46a44f42aa7c2e441e6748c18601ba36a0019ac466
k8s-prometheus-adapter: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:1d14ced707696de3dc0ca7fc585a5240c36e75507639f01c805bef633fbe056c
prometheus-operator: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:2ac9a2c7980da5d32eb7700a5a57abd35e8f78aa2f662dbf2934fa566cacb4ed
prometheus-config-reloader: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:56484d369661fd5b44bf3744d61c6f321594ddbb9a10e861030fc2d87dd63318
kube-rbac-proxy: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:701eb093944140bbb62fa6b966e3285f10671ae824fd1082ee69ae18386fd0a2
prom-label-proxy: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:76264395fb1fb3d9053f64b5e4138735f1e53c9cc203ba7c5bfa4e55a1d27c78
prometheus: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:7f90d53707b67dde283c57549f8ad51b1f7e19134bfacff6266907a404c5eb09
kube-state-metrics: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:855c1f1f53a4c09add1f86f2fcfb2dffa256fd46d3e7d3cf4314a7bbce175f3e
prometheus-alertmanager: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:b8b1c8c96e17e5243310a4457eec7a8eded2320cf0a93ee902fc39000a853168
configmap-reloader: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:ba8b77ca06580db7e59e7ef452c233c2f0cb9f2c9ad9729255a05e3952675a5f
quay.io/openshift/origin-grafana:latest
quay.io/openshift/origin-oauth-proxy:latest

Comment 4 Frederic Branczyk 2019-02-04 16:30:24 UTC
*** Bug 1664862 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.