Bug 1666672 - contextDirectory parameter is set to default value after setting it to empty.
Summary: contextDirectory parameter is set to default value after setting it to empty.
Keywords:
Status: CLOSED DUPLICATE of bug 1605136
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-16 10:45 UTC by Saurabh Sadhale
Modified: 2019-01-16 14:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 14:59:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Saurabh Sadhale 2019-01-16 10:45:20 UTC
Description of problem:

While using the S2I catalog from Web Console, and using these following  JBoss EAP 7.1 (no https), JBoss Web Server 3.1 Apache Tomcat 8 (no https). Setting the parameter to contextDir as empty does point it to the default location. 

Version-Release number of selected component (if applicable):
3.10

How reproducible:
1. Login to the OpenShift Web Console.
2. Select from the Service Catalog the image of  "JBoss EAP 7.1(no https) ".
3. Add the required parameters and keep the contextDir parameter in the Configuration window as empty. 
4. Check in the Build Config we will be able to see value is set to  default. 

Steps to Reproduce:
1.
2.
3.

Actual results:
It should disappear.

Expected results:
It is still visible as default value. 

Additional info:

1. If in a project we have 1 application for 1 repository where the code is located in the root directory. There are no sub-directories so the row  "contextDir: ${CONTEXT_DIR}" is present in the yaml but it shouldn't be there.

Comment 1 Ben Parees 2019-01-16 14:50:25 UTC
I think this has come up before, the console needs a way to distinguish "the user didn't touch this field, use the default from the template" and "the user explicitly set this to emptystring, pass emptystring as the parameter value"

Comment 2 Samuel Padgett 2019-01-16 14:59:42 UTC

*** This bug has been marked as a duplicate of bug 1605136 ***


Note You need to log in before you can comment on or make changes to this bug.