Bug 1666687 - output format for hammer help command is inconsistent
Summary: output format for hammer help command is inconsistent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: 6.7.0
Assignee: satellite6-bugs
QA Contact: Jameer Pathan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-16 11:20 UTC by Jameer Pathan
Modified: 2020-04-14 15:54 UTC (History)
10 users (show)

Fixed In Version: tfm-rubygem-hammer_cli_foreman-0.19.0,tfm-rubygem-hammer_cli_foreman_virt_who_configure-0.0.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-14 15:54:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 27597 0 Low Closed output format for hammer help command is inconsistent 2020-12-11 23:22:47 UTC
Foreman Issue Tracker 27810 0 Normal Closed inconsistently in hammer help command in virt-who configure plugin 2020-12-11 23:23:18 UTC
Red Hat Product Errata RHBA-2020:1455 0 None None None 2020-04-14 15:54:23 UTC

Description Jameer Pathan 2019-01-16 11:20:16 UTC
Description of problem:
output format of help for some hammer command is inconsistent

Version-Release number of selected component (if applicable):
@satellite 6.5.0 snap 11

How reproducible:
always

Steps to Reproduce:
1. output format of help for some hammer command is inconsistent
2. It should be like <shortname>, <name>, <value>, <description>
3. commands are:
- hammer virt-who-config fetch 
- hammer report-template create
- hammer report-template update
 
Actual results:
hammer > virt-who-config > fetch
--------------------------------
Renders a deploy script for the specified virt-who configuration

Usage:
    hammer > virt-who-config > fetch [OPTIONS]

Options:
 --id ID                                  
 --location LOCATION_NAME                Location name
 --location-id LOCATION_ID                
 --location-title LOCATION_TITLE         Location title
 --name NAME                             Name to search by
 --organization ORGANIZATION_NAME        Organization name
 --organization-id ORGANIZATION_ID       Organization ID
 --organization-title ORGANIZATION_TITLE Organization title
 --output, -o FILE                       File where the script will be written.
 -h, --help                              Print help

Expected results:
Usage:
    hammer > virt-who-config > fetch [OPTIONS]

Options:
 --id ID                                  
 --location LOCATION_NAME                Location name
 --location-id LOCATION_ID                
 --location-title LOCATION_TITLE         Location title
 --name NAME                             Name to search by
 --organization ORGANIZATION_NAME        Organization name
 --organization-id ORGANIZATION_ID       Organization ID
 --organization-title ORGANIZATION_TITLE Organization title
 -o, --output FILE                       File where the script will be written.
 -h, --help                              Print help

Additional info:

Comment 3 Oleh Fedorenko 2019-08-12 17:54:03 UTC
Created redmine issue https://projects.theforeman.org/issues/27597 from this bug

Comment 4 Bryan Kearney 2019-09-10 14:07:09 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/27597 has been resolved.

Comment 5 Jameer Pathan 2019-12-23 06:08:58 UTC
Verified

Verified with:
- Satellite 6.7.0 snap 6
- tfm-rubygem-hammer_cli_foreman_virt_who_configure-0.0.5-1.el7sat.noarch
- tfm-rubygem-hammer_cli_foreman-0.19.3-1.el7sat.noarch

Test steps:

Observation:
- Output format of hammer commands is consistent,
 <shortname>, <name>, <value>, <description>

hammer> virt-who-config fetch --help
Usage:
     virt-who-config fetch [OPTIONS]

Options:
 --id ID                                  
 --location LOCATION_NAME                Location name
 --location-id LOCATION_ID                
 --location-title LOCATION_TITLE         Location title
 --name NAME                             Name to search by
 --organization ORGANIZATION_NAME        Organization name
 --organization-id ORGANIZATION_ID       Organization ID
 --organization-title ORGANIZATION_TITLE Organization title
 -h, --help                              Print help
 -o, --output FILE                       File where the script will be written

Comment 8 errata-xmlrpc 2020-04-14 15:54:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1455


Note You need to log in before you can comment on or make changes to this bug.