Bug 1666849 - initial-setup fails to run with recent anaconda (cannot import name 'initThreading' from 'pyanaconda.threading')
Summary: initial-setup fails to run with recent anaconda (cannot import name 'initThre...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
Keywords:
Depends On:
Blocks: ARMTracker F30BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-01-16 18:21 UTC by Adam Williamson
Modified: 2019-01-28 22:32 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-01-28 22:32:19 UTC


Attachments (Terms of Use)

Description Adam Williamson 2019-01-16 18:21:16 UTC
Since the Fedora-Rawhide-20190114.n.0 compose, initial-setup fails to run:

initial-setup[881]: initializing threading
initial-setup[881]: Initial Setup crashed due to unhandled exception:
Traceback (most recent call last):
  File "/usr/libexec/initial-setup/initial-setup-graphical", line 7, in <module>
    is_instance = InitialSetup(gui_mode=True)
  File "/usr/lib/python3.7/site-packages/initial_setup/__init__.py", line 147, in __init__
    from pyanaconda.threading import initThreading
ImportError: cannot import name 'initThreading' from 'pyanaconda.threading' (/usr/lib64/python3.7/site-packages/pyanaconda/threading.py)

This is due to https://github.com/rhinstaller/anaconda/commit/2ffdae666114956e9de49263bfcb727f7da58109 , which appeared in anaconda-30.17-1.fc30 , I think.

Proposing as a Beta blocker, as ARM images are all unusable without initial-setup (cannot create a user or set a root password). https://fedoraproject.org/wiki/Basic_Release_Criteria#Expected_installed_system_boot_behavior - "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system."

Comment 1 Vendula Poncova 2019-01-21 17:08:19 UTC
Fixed in the pull request: https://github.com/rhinstaller/initial-setup/pull/62

Comment 2 Paul Whalen 2019-01-23 15:23:44 UTC
Testing initial-setup-0.3.66-1.fc30, initial-setup fails silently after completion:



Jan 23 10:10:51 rpi3-1.friendly-neighbours.com org.fedoraproject.Anaconda.Modules.Users[852]: DEBUG:anaconda.modules.users.users:Root password set.
Jan 23 10:10:51 rpi3-1.friendly-neighbours.com org.fedoraproject.Anaconda.Modules.Users[852]: DEBUG:anaconda.modules.users.users:Root account has been unlocked.
Jan 23 10:10:51 rpi3-1.friendly-neighbours.com org.fedoraproject.Anaconda.Modules.Users[852]: DEBUG:anaconda.modules.users.users:Root password considered seen in kickstart: False.
Jan 23 10:11:26 rpi3-1.friendly-neighbours.com initial-setup[696]: applying changes
Jan 23 10:11:26 rpi3-1.friendly-neighbours.com initial-setup[696]: executing kickstart
Jan 23 10:11:26 rpi3-1.friendly-neighbours.com initial-setup[696]: skipping <pyanaconda.kickstart.Keyboard object at 0xb16210d0> on line 3
Jan 23 10:11:26 rpi3-1.friendly-neighbours.com initial-setup[696]: skipping <pyanaconda.kickstart.Lang object at 0xb16210b0> on line 5
Jan 23 10:11:26 rpi3-1.friendly-neighbours.com initial-setup[696]: executing <pyanaconda.kickstart.Timezone object at 0xb1664e70> on line 0
Jan 23 10:11:26 rpi3-1.friendly-neighbours.com initial-setup[696]: executing <pyanaconda.kickstart.Group object at 0xb1615210> on line 0
Jan 23 10:11:26 rpi3-1.friendly-neighbours.com initial-setup[696]: Initial Setup crashed due to unhandled exception:
                                                                   Traceback (most recent call last):
                                                                     File "/usr/libexec/initial-setup/initial-setup-text", line 10, in <module>
                                                                       is_instance.run()
                                                                     File "/usr/lib/python3.7/site-packages/initial_setup/__init__.py", line 395, in run
                                                                       self._apply()
                                                                     File "/usr/lib/python3.7/site-packages/initial_setup/__init__.py", line 292, in _apply
                                                                       section.execute(None, self.data, None, u)
                                                                   TypeError: execute() takes 4 positional arguments but 5 were given

Comment 3 Martin Kolman 2019-01-23 17:23:01 UTC
Should be fixed in this PR by vponcova (Thanks!):

https://github.com/rhinstaller/initial-setup/pull/63

Comment 4 Paul Whalen 2019-01-28 20:25:33 UTC
Confirmed fixed in initial-setup-0.3.67-1.fc30.armv7hl, thanks vponcova and mkolman!

Comment 5 Adam Williamson 2019-01-28 22:32:19 UTC
If you confirm it we can go ahead and close the bug - I was just waiting for a new Rawhide compose so the openQA test would run.


Note You need to log in before you can comment on or make changes to this bug.