Bug 16669 - gendiff man page example
Summary: gendiff man page example
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-21 09:31 UTC by giulioo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 09:32:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description giulioo 2000-08-21 09:31:17 UTC
The man page of gendiff explains very well how gendiff works, but then it 
makes an example that is not a perfect choice for the place where it's 
being done (a man page):

===
 I.e. if you were
       going to edit somefile.cpp, copy it  to  somefile.cpp.save
       before  editing  it.   Then  edit  the  first  copy (some-
       file.cpp).
 
       After editing all the files you need to edit in this fash-
       ion, enter the directory one level above where your source
       code resides, and then type
           $ gendiff somedirectory .orig > mydiff-orig.patch
===

if you backup your files with .save then gendiff wants .save as extension, 
not .orig.
Since this is a manpage, where new users will look at, it would be better 
to use the backup extension consistently.

Comment 1 Jeff Johnson 2000-08-24 15:57:18 UTC
FIxed in rpm CVS. Thanks for noticing and reporting.


Note You need to log in before you can comment on or make changes to this bug.