Bug 1666908 - cluster-ingress-operator high API request rates
Summary: cluster-ingress-operator high API request rates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.1.0
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
: 1666846 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-16 21:56 UTC by Seth Jennings
Modified: 2019-06-04 10:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
cluster-ingress-operator.png (86.91 KB, image/png)
2019-01-16 21:56 UTC, Seth Jennings
no flags Details


Links
System ID Priority Status Summary Last Updated
Github https://github.com/openshift cluster-ingress-operator pull 105 None None None 2019-01-16 21:58:45 UTC
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:01 UTC

Description Seth Jennings 2019-01-16 21:56:47 UTC
Created attachment 1521143 [details]
cluster-ingress-operator.png

The cluster-ingress-operator is submitting high levels of API request (see attached image)

In all about 20 requests per second.  This is not typical of a properly running operator.

Comment 1 Seth Jennings 2019-01-16 22:01:48 UTC
Likely addressed by https://github.com/openshift/cluster-ingress-operator/pull/105

Comment 2 Seth Jennings 2019-01-17 15:54:04 UTC
I can confirm that https://github.com/openshift/cluster-ingress-operator/pull/105 fixed this. Thanks!

Comment 3 Dan Mace 2019-01-24 12:50:40 UTC
*** Bug 1666846 has been marked as a duplicate of this bug. ***

Comment 5 Hongan Li 2019-01-25 09:16:28 UTC
the issue has been fixed as Comment 2.

and wildcard dns record also is created.

Comment 8 errata-xmlrpc 2019-06-04 10:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.