Bug 166694 - xen kernels don't support kprobes
Summary: xen kernels don't support kprobes
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Markus Armbruster
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 179599
TreeView+ depends on / blocked
 
Reported: 2005-08-24 18:00 UTC by Martin Hunt
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 09:51:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Hunt 2005-08-24 18:00:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
It would be very useful if the Fedora xen kernels worked with kprobes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download devel xen kernel
2. Verify kprobes not configured
3.
  

Additional info:

Comment 3 Stephen Tweedie 2006-09-20 20:19:38 UTC
kprobes is on in our current rawhide kernel-xen config.  But systemtap is broken
in other ways (it fails to compile the stap scripts due to a #warning in
<linux/config.h>).  It's apparently fixed in upstream systemtap CVS, so when the
fix propagates to rawhide I'll be able to test if it's actually working.
 

Comment 4 Stephen Tweedie 2006-09-21 09:51:40 UTC
I got a direct kprobes test case from fche; all works fine on a Xen domU.


Note You need to log in before you can comment on or make changes to this bug.