Bug 16670 - kernel installation problem
Summary: kernel installation problem
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-21 10:36 UTC by thomas.mangin
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 17:47:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description thomas.mangin 2000-08-21 10:36:51 UTC
I wonder why you are not automaticly creating the initrd file after a 
kernel installation as it can leave the system in a reallly broken state.

kernel RPM can be installed too with a -U option, as a consequence the old 
kernel is removed and mkinitrd can not be used anymore as loop.o was 
deleted !

RPM spec files would perhaps benefit of a way to restrict install option 
(install only, update only or install & update).

Comment 1 Michael K. Johnson 2000-08-21 14:15:38 UTC
Our current source tree does a modprobe loop in the preinstall
so that the loop module will be loaded and mkinitrd will work.


Comment 2 Need Real Name 2001-02-22 23:58:27 UTC
I just upgraded my kernel with rpm's -U option from both 2.2.14-5 and 2.2.16-
22smp to the 2.2.17-14smp. Immediately afterwards, an lsmod showed no loop 
module loaded.

Comment 3 Michael K. Johnson 2001-02-23 17:47:43 UTC
Oops.  I only added it for the uniprocessor kernel before.  I have
just added that for the smp and enterprise kernels as well.  Will
be fixed in the next 2.2 kernel we release.  Thanks for pointing
this oversight out.

Comment 4 Michael K. Johnson 2001-12-06 17:28:20 UTC
Since we have released errata kernels after my last comment, I am
closing this bug report.


Note You need to log in before you can comment on or make changes to this bug.