Bug 1667027 - [olm] failed: error parsing bundle: cannot convert int64 to float64
Summary: [olm] failed: error parsing bundle: cannot convert int64 to float64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-17 09:31 UTC by Fan Jia
Modified: 2019-06-04 10:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:09 UTC

Description Fan Jia 2019-01-17 09:31:33 UTC
Description of problem:
The CSV won’t created if installing the operator through the Operator Hub.

Version-Release number of selected component (if applicable):
1) clusterversion:4.0.0-0.nightly-2019-01-15-184339
2) marketplace image commit:
https://github.com/operator-framework/operator-marketplace/commit/fbfcb78e3e6a7ea0b18d7dd09d7e5ddc23e33a5a
3) olm image commit:
https://github.com/operator-framework/operator-marketplace/commit/fbfcb78e3e6a7ea0b18d7dd09d7e5ddc23e33a5a
4) console image commit:
https://github.com/openshift/console/commit/c494be21acef42767716791e167f055f96045e0e

How reproducible:
always

Steps to Reproduce:
1. install the cluster and choose one operator in page “Catalog-→Operator Hub”,click the install button on the operator detail page. 
2. click the “Subsrcibe” button on the subscrbe page(choose OG global-operators).
3. check the Installed Operators #oc get csv -n openshift-operators

Actual results:
1.The operator can’t be installed ,there is no csv in ns openshift-operators.
There are error messages in the catalog-operator of olm:

“time="2019-01-17T06:43:19Z" level=info msg="retrying openshift-operators/etcd"”E0117 06:43:19.970979       1 queueinformer_operator.go:155] Sync "openshift-operators/etcd" failed: {etcd alpha {marketplace-enabled-operators-community openshift-operators}} not found: rpc error: code = Unavailable desc = all SubConns are in TransientFailure, latest connection error: connection error: desc = "transport: Error while dialing dial tcp 172.30.177.243:50051: connect: no route to host"time="2019-01-17T06:43:19Z" level=info msg="retrying openshift-operators/etcd"E0117 06:43:19.981368       1 queueinformer_operator.go:155] Sync "openshift-operators/etcd" failed: error parsing bundle: cannot convert int64 to float64

Expected results:
1.operators can be installed successfully without error

Additional info:

Comment 1 Jian Zhang 2019-01-18 10:30:34 UTC
It's already traced in jira: https://jira.coreos.com/browse/ALM-850
Fix PRs:
https://github.com/operator-framework/operator-lifecycle-manager/pull/672
https://github.com/operator-framework/operator-registry/pull/19

The fixed PR commit is 23f22b86c17bebde892132aaede74a3635606408.
But the latest image of the OLM is: 
[jzhang@dhcp-140-18 ~]$ oc adm release info registry.svc.ci.openshift.org/ocp/release:4.0.0-0.nightly-2019-01-17-185315 --pullspecs |grep lifecycle
  operator-lifecycle-manager                    registry.svc.ci.openshift.org/ocp/4.0-art-latest-2019-01-17-185315@sha256:c33a03fde272464ff2f952ee18902c5726550ca047cedfbf4c9c2ebcfe8d4b75
And, its version is:
[jzhang@dhcp-140-18 ~]$ oc image info registry.svc.ci.openshift.org/ocp/4.0-art-latest-2019-01-17-185315@sha256:c33a03fde272464ff2f952ee18902c5726550ca047cedfbf4c9c2ebcfe8d4b75|grep io.openshift.source-repo-commit
               io.openshift.source-repo-commit=215e4f68101c2a31856a0e37058b231b7825d1be
commit list: https://github.com/operator-framework/operator-lifecycle-manager/commits/master

So, the fixed PR hasn't been merged in the latest OLM image on OCP.

Comment 4 Fan Jia 2019-01-22 10:02:31 UTC
It is ok in clusterversion:4.0.0-0.alpha-2019-01-20-082408

Comment 7 errata-xmlrpc 2019-06-04 10:42:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.