Bug 166705 - Installer doesn't recognize upgradeable installation
Installer doesn't recognize upgradeable installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 15:48 EDT by Rene Bauer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 10:52:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rene Bauer 2005-08-24 15:48:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Note: This is a bug report with solution, so you can close it immediately. Since we found a few obviously related bugs still open, we hope this helps to resolve those bugs.

We were trying to update from a FC2 installation to FC4, but FC4 was unable to find the existing installation. After trying to install with the "upgradeany" option the root partition was found. There was a warning saying /etc/redhat-release could not be found, so we investigated a bit more. The problem is, that on our installation, we dont know why, /etc/redhat-release is an absolute link to /etc/fedora-release. During the install process the current installation is mounted to /mnt/sysimage and then the absolute link can not be resolved and the file is not found by anaconda. The solution is simple, just relink redhat-release relative to fedora-release and everything works as expected.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot from FC4 boot cd
2. use text or graphical installer
3. answer the following question until FC tries to find existing installations
  

Actual Results:  Anaconda does not find existing installation and offers only fresh install

Expected Results:  Anaconda finding the existing installation ...

Additional info:

We are not sure but we think the FC2 installation was a clean install, meaning that the absolute link may have been created during the FC2 install.

Since anaconda seems to be only looking for the redhat-release file, it might be better to also look for the fedora-release file if redhat-release can not be found.
Comment 1 Jeremy Katz 2005-08-25 10:52:47 EDT
Absolute symlinks will screw up a number of things on an upgrade since the root
of the filesystem is mounted under a chroot.  There's, unfortunately, not a lot
that can be done to work around that :(
Comment 2 Rene Bauer 2005-08-25 11:23:09 EDT
(In reply to comment #1)
> Absolute symlinks will screw up a number of things on an upgrade since the root
> of the filesystem is mounted under a chroot.  There's, unfortunately, not a lot
> that can be done to work around that :(

As I said, wouldn't it be better to not only look for redhat-release, but also
look for fedora-release too, if the redhat-release file can not be found?
Looking at the code this is currently not the case. It is only a few linces of
code in the scripts of anaconda and will save you guys from a lot of strange bug
reports ...

I would also be happy if Red Hat/Fedora could make sure that the absolute
symlink was not actually created by the installer.

Note You need to log in before you can comment on or make changes to this bug.