Bug 166706 - UnmarshalException after unexport
UnmarshalException after unexport
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.4.2-bea (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On: 170822
Blocks: 168424 168430
  Show dependency treegraph
 
Reported: 2005-08-24 16:00 EDT by Archit Shah
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0008
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:46:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case (905 bytes, application/octet-stream)
2005-08-24 16:02 EDT, Archit Shah
no flags Details

  None (edit)
Description Archit Shah 2005-08-24 16:00:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
After unexporting a remote object during execution of a remote method, remote calls to the object fail with an UnmarshalException instead of a NoSuchObjectException.

Version-Release number of selected component (if applicable):
java-1.4.2-bea-1.4.2.05-1jpp_13rh

How reproducible:
Always

Steps to Reproduce:
1. export an object (can extend either PortableRemoteObject or UnicastRemoteObject) with a remote method such as:

    public void remove() throws RemoteException {
        unexportObject(this);
    }



2. Use a client to interact with the object:

        h.remove();
        try {
            h.ping();
            throw new IllegalStateException("expected NoSuchObjectException");
        } catch (NoSuchObjectException nsoe) {
            System.out.println("success");
        }


Actual Results:  Got UnmarshalException:

java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is:
        java.io.EOFException
        at sun.rmi.transport.StreamRemoteCall.executeCall()V(StreamRemoteCall.java:203)
        at sun.rmi.server.UnicastRef.invoke(Ljava.rmi.Remote;Ljava.lang.reflect.Method;[Ljava.lang.Object;J)Ljava.lang.Object;(UnicastRef.java:133)
        at HelloImpl_Stub.ping()V(Unknown Source)
        at Client.main([Ljava.lang.String;)V(Client.java:12)
Caused by: java.io.EOFException
        at java.io.DataInputStream.readByte()B(Unknown Source)
        at sun.rmi.transport.StreamRemoteCall.executeCall()V(StreamRemoteCall.java:189)
        ... 3 more


Expected Results:  Expected NoSuchObjectException 

Additional info:
Comment 1 Archit Shah 2005-08-24 16:02:34 EDT
Created attachment 118089 [details]
Test case
Comment 2 Johan Walles 2005-09-09 07:23:25 EDT
Quoting from a mail I got from Archit:

"
I verified the bug is also present in the latest version we have received (for
_35rh):

# java -version
java version "1.4.2_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
BEA WebLogic JRockit(TM) 1.4.2_05 JVM R24.4.1-1 (build
ari-38317-20041124-1225-linux-ia32, Native Threads, GC strategy: parallel)

The bug has been fixed in the 1.4.2_08 version:

# java -version
java version "1.4.2_08"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_08-b03)
BEA WebLogic JRockit(TM) 1.4.2_08 JVM R24.5.0-40 (build
ari-46046-20050609-2056-linux-ia32, Native Threads, GC strategy: parallel)
"
Comment 3 Thomas Fitzsimmons 2005-12-08 11:52:23 EST
This bug is fixed by the packages in RHBA-2006:008-03 and RHBA-2006:009-02.  So
this will be fixed in RHEL3U7 and RHEL4U3.
Comment 4 Tom Kincaid 2006-01-03 15:54:20 EST
I verified the test case works on x86_64.
Comment 8 Red Hat Bugzilla 2006-03-07 13:27:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0009.html
Comment 9 Red Hat Bugzilla 2006-03-15 10:46:09 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0008.html

Note You need to log in before you can comment on or make changes to this bug.