Bug 1667164 - Satellite unable to enable repository-set because of missing $basearch in the repository URL
Summary: Satellite unable to enable repository-set because of missing $basearch in the...
Keywords:
Status: CLOSED DUPLICATE of bug 1666968
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Released
Assignee: Jonathon Turel
QA Contact: vijsingh
URL:
Whiteboard:
Depends On:
Blocks: 1661283
TreeView+ depends on / blocked
 
Reported: 2019-01-17 15:28 UTC by Radovan Drazny
Modified: 2019-10-07 17:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-22 19:38:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Radovan Drazny 2019-01-17 15:28:46 UTC
Description of problem:
It is not possible to enable a repository-set with a repo URL missing the "$basearch" variable. Because of this it is not possible to enable official RHEL 8 Beta repos in Satellite 6.5.

Version-Release number of selected component (if applicable):
Sat 6.5 Snap 11

How reproducible:
always

Steps to Reproduce:
1. Have a manifest with a Red Hat Beta entitlemen uploaded to the Satellite 6.5
2. In "Content -> Red Hat Repositories" enable Beta in the dropbox, and find Red Hat Enterprise Linux 8 for x86_64 - BaseOS Beta (RPMs) (rhel-8-for-x86_64-baseos-beta-rpms).
3. Try to enable the x86_64 repo

Actual results:
The operation fails with a message: "basearch cannot be specified for Red Hat Enterprise Linux 8 for x86_64 - BaseOS Beta (RPMs) as that information is not substitutable in /content/beta/rhel8/8/x86_64/baseos/os" 

Expected results:
Repo is enabled.

Additional info:
The same operation using hammer:

===================================================================
hammer> repository-set info --organization-id 1 --id 7568
ID:                   7568
Name:                 Red Hat Enterprise Linux 8 for x86_64 - BaseOS Beta (RPMs)
Type:                 yum
URL:                  /content/beta/rhel8/8/x86_64/baseos/os
GPG Key:              file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta,file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Label:                rhel-8-for-x86_64-baseos-beta-rpms
Enabled Repositories:

hammer> repository-set enable --organization-id 1 --id 7568
Could not enable repository:
  basearch cannot be specified for Red Hat Enterprise Linux 8 for x86_64 - BaseOS Beta (RPMs) as that information is not substitutable in /content/beta/rhel8/8/x86_64/baseos/os 
===================================================================

The same operation in Sat 6.4 works without any problems.

===================================================================
hammer> repository-set info --organization-id 1 --product-id 25 --id 7568                                                                                                                                           
ID:                   7568
Name:                 Red Hat Enterprise Linux 8 for x86_64 - BaseOS Beta (RPMs)
Type:                 yum
URL:                  /content/beta/rhel8/8/x86_64/baseos/os
GPG Key:              file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta,file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Label:                rhel-8-for-x86_64-baseos-beta-rpms
Enabled Repositories:

hammer> repository-set enable --organization-id 1 --product-id 25 --id 7568
Repository enabled
===================================================================

The URL really doesn't contain the $basearch var, but Sat 6.4 was apparently much less strict about this (or the $basearch wasn't set by default).

Comment 5 John Mitsch 2019-01-22 19:31:46 UTC
It looks like this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1666968

Comment 6 John Mitsch 2019-01-22 19:38:35 UTC

*** This bug has been marked as a duplicate of bug 1666968 ***


Note You need to log in before you can comment on or make changes to this bug.