Bug 1667315 - CLO should not make changes to logging stack when managementState is UnManaged
Summary: CLO should not make changes to logging stack when managementState is UnManaged
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-18 06:49 UTC by Qiaoling Tang
Modified: 2019-06-04 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:09 UTC

Description Qiaoling Tang 2019-01-18 06:49:37 UTC
Description of problem:
Deploy logging, set "managementState: UnManaged" in clusterlogging CR, log collection type is fluentd, then change log collection type to rsyslog in clusterlogging CR, wait for a while, check pod, there are two kinds of log collector in the ns:
$ oc get pod
NAME                                                  READY     STATUS      RESTARTS   AGE
cluster-logging-operator-77fd7bcbb8-6dj74             1/1       Running     0          49m
elasticsearch-clientdatamaster-0-1-84d764899d-x57xd   1/1       Running     0          35m
elasticsearch-clientdatamaster-0-2-56984bb76c-mf2t5   1/1       Running     0          35m
elasticsearch-clientdatamaster-0-3-7cd67f75dd-9btxc   1/1       Running     0          35m
elasticsearch-operator-86cc7cb548-hgkfh               1/1       Running     0          5h
fluentd-4h2h4                                         1/1       Running     0          11m
fluentd-7jmz2                                         1/1       Running     0          11m
fluentd-8qp49                                         1/1       Running     0          11m
fluentd-9txtr                                         1/1       Running     0          11m
fluentd-c7skq                                         1/1       Running     0          11m
fluentd-dscn8                                         1/1       Running     0          11m
kibana-648865b454-hzvcj                               2/2       Running     0          53m
rsyslog-jnpfq                                         1/1       Running     0          3m
rsyslog-l5w66                                         1/1       Running     0          3m
rsyslog-nblvx                                         1/1       Running     0          3m
rsyslog-qbfrz                                         1/1       Running     0          3m
rsyslog-rdvcf                                         1/1       Running     0          3m
rsyslog-sxxd6                                         1/1       Running     0          3m
$ oc get ds
NAME      DESIRED   CURRENT   READY     UP-TO-DATE   AVAILABLE   NODE SELECTOR   AGE
fluentd   6         6         6         6            6           <none>          11m
rsyslog   6         6         6         6            0           <none>          3m

$ oc get clusterlogging -o yaml 
apiVersion: v1
items:
- apiVersion: logging.openshift.io/v1alpha1
  kind: ClusterLogging
  metadata:
    creationTimestamp: 2019-01-18T01:19:02Z
    generation: 1
    name: example
    namespace: openshift-logging
    resourceVersion: "263964"
    selfLink: /apis/logging.openshift.io/v1alpha1/namespaces/openshift-logging/clusterloggings/example
    uid: 0a592282-1abf-11e9-ac86-06a5d6fd69d6
  spec:
    collection:
      logs:
        fluentd:
          resources: {}
        rsyslog:
          resources: {}
        type: rsyslog
    curation:
      curator:
        resources: {}
        schedule: 30 6 * * *
      type: curator
    logStore:
      elasticsearch:
        nodeCount: 3
        redundancyPolicy: SingleRedundancy
        resources: {}
        storage: {}
      type: elasticsearch
    managementState: UnManaged
 

Version-Release number of selected component (if applicable):
$ oc get pod cluster-logging-operator-77fd7bcbb8-6dj74 -o yaml |grep image
    image: quay.io/openshift/origin-cluster-logging-operator:latest
    imagePullPolicy: IfNotPresent
  imagePullSecrets:
    image: quay.io/openshift/origin-cluster-logging-operator:latest
    imageID: quay.io/openshift/origin-cluster-logging-operator@sha256:af7998d54bb770dc4b1944d2ebc0a656b94f160df05bb92d02ea16bdeffe09a5


How reproducible:
Always

Steps to Reproduce:
1.Deploy logging, set "managementState: UnManaged" in clusterlogging CR, default log collection is fluentd
2.change log collection type to rsyslog
3.check pods

Actual results:


Expected results:


Additional info:

Comment 2 Qiaoling Tang 2019-01-25 08:26:09 UTC
Verified in quay.io/openshift/origin-cluster-logging-operator@sha256:9be38553042fa32720c4b5237c7eadb974546c9e702a0aa44e3fe089dc21ac8b

Comment 5 errata-xmlrpc 2019-06-04 10:42:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.