Bug 166737 - RHEL3: odd shape cursor in emacs when background is not white
RHEL3: odd shape cursor in emacs when background is not white
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: emacs (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 22:45 EDT by Boris Vinarsky
Modified: 2015-01-07 19:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:55:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Vinarsky 2005-08-24 22:45:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
When emacs is started with any backgroung except for white cursor inside emacs window takes a bold X shape. It makes inconvenient for users to select text.  Moving cursor to the icon bar above text window fixes the cursor shape. Moving cursor to the menu bar changes the shape back to X. After the exit cursor stays X until it is pointed to another window, where it becomes normal again. 

Version-Release number of selected component (if applicable):
emacs-21.3-4.1

How reproducible:
Always

Steps to Reproduce:
1. emacs -bg gray
2. have fun with the cursor
3.
  

Actual Results:  See description

Expected Results:  Arrow or I shaped cursor.

Additional info:

The previous version emacs-21.2-18 did not suffer from that.

I tested this issue under GNOME, KDE, and Failsafe. The result is the same. Prior to testing I removed all files from home directory including ~/.emacs except for .cshrc.

emacs -bg white works fine.

Setting emacs.background X resource to any color produces the same result.
Comment 1 Jens Petersen 2005-09-30 00:54:31 EDT
Does this still happen with RHEL3 U6 ?

What did you upgrade from?  (emacs-21.2 hasn't 

I can't reproduce this on RHEL4 or Fedora Core.
Comment 2 Jens Petersen 2005-09-30 00:55:49 EDT
Sorry about the incomplete sentence.  That should say:
"(emacs-21.2 hasn't shipped in RHEL3.)"
Comment 3 Boris Vinarsky 2005-09-30 17:16:48 EDT
I used a system that was installed from original CDs I received from Dell 
along with the system. I did not use any external source for emacs.
Today I have upgraded a system to everything latest:
[root@chico root]# cat /etc/redhat-release 
Red Hat Enterprise Linux WS release 3 (Taroon Update 6)
Currently on that system:
[root@chico root]# rpm -q emacs
emacs-21.3-4.7
I tested emacs with not-white backgroup. The issue is still there, no changes.
Comment 4 RHEL Product and Program Management 2007-10-19 14:55:24 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.