Bug 1667468 - youtube-dl-2019.01.24 is available [NEEDINFO]
Summary: youtube-dl-2019.01.24 is available
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-18 14:36 UTC by Upstream Release Monitoring
Modified: 2019-04-03 18:50 UTC (History)
6 users (show)

Fixed In Version: youtube-dl-2019.01.24-1.fc29 youtube-dl-2019.01.30-1.fc28 youtube-dl-2019.01.30-2.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-01-27 03:00:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
hobbes1069: needinfo? (opensource)
hobbes1069: needinfo? (opensource)


Attachments (Terms of Use)

Description Upstream Release Monitoring 2019-01-18 14:36:26 UTC
Latest upstream release: 2019.01.17
Current version/release in rawhide: 2018.12.17-1.fc30
URL: http://youtube-dl.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/5292/

Comment 1 Upstream Release Monitoring 2019-01-22 22:06:35 UTC
Latest upstream release: 2019.01.23
Current version/release in rawhide: 2018.12.17-1.fc30
URL: http://youtube-dl.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/5292/

Comment 2 Upstream Release Monitoring 2019-01-23 19:17:56 UTC
Latest upstream release: 2019.01.24
Current version/release in rawhide: 2018.12.17-1.fc30
URL: http://youtube-dl.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/5292/

Comment 3 Richard Shaw 2019-01-24 18:59:42 UTC
The version in the repos (Dec 2018) no longer functions, The package *NEEDS* to be updated.

Comment 4 Matěj Cepl 2019-01-24 20:01:52 UTC
(In reply to Richard Shaw from comment #3)
> The version in the repos (Dec 2018) no longer functions, The package *NEEDS*
> to be updated.

If you need the change immediately, then you can do it yourself. https://is.gd/AI2nTL

There is really nobody spending quality time with this package, and although it is quite easy to update, it needs to be done too often. I no longer want to package for Fedora (switched work and distros), so if you want to step up to the challenge, you are more than welcome. After reading the appropriate literature and doing all other required dance steps, feel free to ask for any questions about this package.

Comment 5 Richard Shaw 2019-01-24 21:26:23 UTC
I already looked at updating it but I didn't understand the process or purpose for the gpg signature for the source archive.

Comment 6 Matěj Cepl 2019-01-25 08:58:45 UTC
(In reply to Richard Shaw from comment #5)
> I already looked at updating it but I didn't understand the process or
> purpose for the gpg signature for the source archive.

Don't think about it, it works automagically. Just don't forget to download (and upload with fedpkg new-source) .sig file together with the tarball.

Comment 7 Matěj Cepl 2019-01-25 09:03:23 UTC
Actually, the process is very simple:

1. git checkout master && git pull
2. edit .spec file and correct Version
3. rm old-tarball-and-sig-file
4. spectool -g *.spec
5. fedpkg new-sources youtube-dl-*.tar.gz*
6. fedpkg build  # Just to be sure that everything works
7. for dist in el6 epel7 f28 f29 ; do fedpkg switch-branch $dist && git merge master && git push && fedpkg build --nowait ; done
(adjust supported Fedora distros as needed)

Look at the appropriate web pages with individual builds, and when everything is allright, fire new update at bodhi.fedoraproject.org.

Done.

Comment 8 Richard Shaw 2019-01-25 13:52:15 UTC
(In reply to Matěj Cepl from comment #6)
> (In reply to Richard Shaw from comment #5)
> > I already looked at updating it but I didn't understand the process or
> > purpose for the gpg signature for the source archive.
> 
> Don't think about it, it works automagically. Just don't forget to download
> (and upload with fedpkg new-source) .sig file together with the tarball.

Ok, I'm a long time packager so I'm familiar with the rest of it but never run into a signature before. I was trying to do a local mock build but couldn't due to the new signature not being generated without modifying the spec file and I was trying not to do that just yet.

Till seems to be the main admin and has not responded, I don't mind taking over the package if he's not interested in maintaining it anymore.

Comment 9 Matěj Cepl 2019-01-25 14:19:22 UTC
(In reply to Richard Shaw from comment #8)
> Ok, I'm a long time packager so I'm familiar with the rest of it but never
> run into a signature before. I was trying to do a local mock build but
> couldn't due to the new signature not being generated without modifying the
> spec file and I was trying not to do that just yet.

The whole magic is line 30:

gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}

and it just works. You only have to keep *.tar.gz and *.sig file in sync.

> Till seems to be the main admin and has not responded, I don't mind taking
> over the package if he's not interested in maintaining it anymore.

Yeah, I was maintaining this package in his place for the last year or so, and he seems to gave up on this. Contact him.

Comment 10 Fedora Update System 2019-01-25 15:05:09 UTC
youtube-dl-2019.01.24-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f694e52930

Comment 11 Fedora Update System 2019-01-25 15:05:12 UTC
youtube-dl-2019.01.24-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a8a9673f3c

Comment 12 Fedora Update System 2019-01-25 15:05:16 UTC
youtube-dl-2019.01.24-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-03cd843798

Comment 13 Fedora Update System 2019-01-26 01:43:53 UTC
youtube-dl-2019.01.24-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a8a9673f3c

Comment 14 Fedora Update System 2019-01-26 02:29:56 UTC
youtube-dl-2019.01.24-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-03cd843798

Comment 15 Fedora Update System 2019-01-26 03:29:14 UTC
youtube-dl-2019.01.24-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f694e52930

Comment 16 Fedora Update System 2019-01-27 03:00:44 UTC
youtube-dl-2019.01.24-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-01-29 22:51:20 UTC
youtube-dl-2019.01.30-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-825994a31c

Comment 18 Fedora Update System 2019-01-29 22:51:33 UTC
youtube-dl-2019.01.30-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-2677b17fbd

Comment 19 Fedora Update System 2019-01-30 02:22:58 UTC
youtube-dl-2019.01.30-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-2677b17fbd

Comment 20 Fedora Update System 2019-01-30 03:01:45 UTC
youtube-dl-2019.01.30-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-825994a31c

Comment 21 Fedora Update System 2019-02-09 01:51:49 UTC
youtube-dl-2019.01.30-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2019-03-12 16:38:37 UTC
python-trololio-1.0-2.el7 python-typing-3.5.2.2-4.el7 python-unidiff-0.5.4-2.el7 python-vcstools-0.1.40-2.el7 python-vxi11-0.9-2.el7 python-wcwidth-0.1.7-3.el7 python-whoosh-2.7.4-4.el7 python-wrapt-1.10.4-8.el7 python-www-authenticate-0.9.2-4.el7 python-xapp-1.0.1-9.el7 python-xlrd-1.0.0-7.el7 python-yamlordereddictloader-0.4.0-2.el7 python-yara-3.8.1-2.el7.1 python-zope-component-4.1.0-5.el7 python-zope-configuration-4.0.3-13.el7 python-zope-exceptions-4.0.5-6.el7 python-zope-i18nmessageid-4.0.3-4.el7 python-zope-schema-4.4.1-4.el7 python-zope-testing-4.6.1-8.el7 pyxdg-0.25-7.el7 qpid-proton-0.26.0-2.el7 root-6.16.00-4.el7 sasutils-0.3.9-2.el7 scapy-2.4.0-3.el7 shiboken-1.2.4-10.el7 spglib-1.11.1-2.el7 urjtag-2017.10-3.el7 uwsgi-2.0.17.1-2.el7 xapps-1.0.4-14.el7 xed-1.6.2-3.el7 xplayer-1.6.0-6.el7 xrootd-4.9.0-2.el7 xviewer-plugins-1.2.0-6.el7 yamllint-1.15.0-2.el7 youtube-dl-2019.01.30-2.el7 yubikey-piv-manager-1.4.2-6.el7 znc-1.7.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ed3564d906

Comment 23 Fedora Update System 2019-03-12 22:42:48 UTC
python-trololio-1.0-2.el7, python-typing-3.5.2.2-4.el7, python-unidiff-0.5.4-2.el7, python-vcstools-0.1.40-2.el7, python-vxi11-0.9-2.el7, python-wcwidth-0.1.7-3.el7, python-whoosh-2.7.4-4.el7, python-wrapt-1.10.4-8.el7, python-www-authenticate-0.9.2-4.el7, python-xapp-1.0.1-9.el7, python-xlrd-1.0.0-7.el7, python-yamlordereddictloader-0.4.0-2.el7, python-yara-3.8.1-2.el7.1, python-zope-component-4.1.0-5.el7, python-zope-configuration-4.0.3-13.el7, python-zope-exceptions-4.0.5-6.el7, python-zope-i18nmessageid-4.0.3-4.el7, python-zope-schema-4.4.1-4.el7, python-zope-testing-4.6.1-8.el7, pyxdg-0.25-7.el7, qpid-proton-0.26.0-2.el7, root-6.16.00-4.el7, sasutils-0.3.9-2.el7, scapy-2.4.0-3.el7, shiboken-1.2.4-10.el7, spglib-1.11.1-2.el7, urjtag-2017.10-3.el7, uwsgi-2.0.17.1-2.el7, xapps-1.0.4-14.el7, xed-1.6.2-3.el7, xplayer-1.6.0-6.el7, xrootd-4.9.0-2.el7, xviewer-plugins-1.2.0-6.el7, yamllint-1.15.0-2.el7, youtube-dl-2019.01.30-2.el7, yubikey-piv-manager-1.4.2-6.el7, znc-1.7.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ed3564d906

Comment 24 Fedora Update System 2019-03-19 13:58:13 UTC
python-trololio-1.0-2.el7 python-typing-3.5.2.2-4.el7 python-unidiff-0.5.4-2.el7 python-vcstools-0.1.40-2.el7 python-vxi11-0.9-2.el7 python-wcwidth-0.1.7-3.el7 python-whoosh-2.7.4-4.el7 python-wrapt-1.10.4-8.el7 python-www-authenticate-0.9.2-4.el7 python-xapp-1.0.1-9.el7 python-xlrd-1.0.0-7.el7 python-yamlordereddictloader-0.4.0-2.el7 python-yara-3.8.1-2.el7.1 python-zope-component-4.1.0-5.el7 python-zope-configuration-4.0.3-13.el7 python-zope-exceptions-4.0.5-6.el7 python-zope-i18nmessageid-4.0.3-4.el7 python-zope-schema-4.4.1-4.el7 python-zope-testing-4.6.1-8.el7 pyxdg-0.25-7.el7 qpid-proton-0.26.0-2.el7 rlwrap-0.43-2.el7 root-6.16.00-4.el7 sasutils-0.3.9-2.el7 scapy-2.4.0-3.el7 shiboken-1.2.4-10.el7 spglib-1.11.1-2.el7 urjtag-2017.10-3.el7 uwsgi-2.0.17.1-2.el7 xapps-1.0.4-14.el7 xed-1.6.2-3.el7 xplayer-1.6.0-6.el7 xrootd-4.9.0-2.el7 xviewer-plugins-1.2.0-6.el7 yamllint-1.15.0-2.el7 youtube-dl-2019.01.30-2.el7 yubikey-piv-manager-1.4.2-6.el7 znc-1.7.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ed3564d906

Comment 25 Fedora Update System 2019-03-20 19:58:49 UTC
python-trololio-1.0-2.el7, python-typing-3.5.2.2-4.el7, python-unidiff-0.5.4-2.el7, python-vcstools-0.1.40-2.el7, python-vxi11-0.9-2.el7, python-wcwidth-0.1.7-3.el7, python-whoosh-2.7.4-4.el7, python-wrapt-1.10.4-8.el7, python-www-authenticate-0.9.2-4.el7, python-xapp-1.0.1-9.el7, python-xlrd-1.0.0-7.el7, python-yamlordereddictloader-0.4.0-2.el7, python-yara-3.8.1-2.el7.1, python-zope-component-4.1.0-5.el7, python-zope-configuration-4.0.3-13.el7, python-zope-exceptions-4.0.5-6.el7, python-zope-i18nmessageid-4.0.3-4.el7, python-zope-schema-4.4.1-4.el7, python-zope-testing-4.6.1-8.el7, pyxdg-0.25-7.el7, qpid-proton-0.26.0-2.el7, rlwrap-0.43-2.el7, root-6.16.00-4.el7, sasutils-0.3.9-2.el7, scapy-2.4.0-3.el7, shiboken-1.2.4-10.el7, spglib-1.11.1-2.el7, urjtag-2017.10-3.el7, uwsgi-2.0.17.1-2.el7, xapps-1.0.4-14.el7, xed-1.6.2-3.el7, xplayer-1.6.0-6.el7, xrootd-4.9.0-2.el7, xviewer-plugins-1.2.0-6.el7, yamllint-1.15.0-2.el7, youtube-dl-2019.01.30-2.el7, yubikey-piv-manager-1.4.2-6.el7, znc-1.7.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ed3564d906

Comment 26 Fedora Update System 2019-03-25 18:44:41 UTC
python-trololio-1.0-2.el7 python-typing-3.5.2.2-4.el7 python-unidiff-0.5.4-2.el7 python-vcstools-0.1.40-2.el7 python-vxi11-0.9-2.el7 python-wcwidth-0.1.7-3.el7 python-whoosh-2.7.4-4.el7 python-wrapt-1.10.4-8.el7 python-www-authenticate-0.9.2-4.el7 python-xapp-1.0.1-9.el7 python-xlrd-1.0.0-7.el7 python-yamlordereddictloader-0.4.0-2.el7 python-yara-3.8.1-2.el7.1 python-zope-component-4.1.0-5.el7 python-zope-configuration-4.0.3-13.el7 python-zope-exceptions-4.0.5-6.el7 python-zope-i18nmessageid-4.0.3-4.el7 python-zope-schema-4.4.1-4.el7 python-zope-testing-4.6.1-8.el7 python3-rpm-4.11.3-3.el7 pyxdg-0.25-7.el7 qpid-proton-0.26.0-2.el7 rlwrap-0.43-2.el7 root-6.16.00-4.el7 sasutils-0.3.9-2.el7 scapy-2.4.0-3.el7 shiboken-1.2.4-10.el7 spglib-1.11.1-2.el7 urjtag-2017.10-3.el7 uwsgi-2.0.17.1-2.el7 xapps-1.0.4-14.el7 xed-1.6.2-3.el7 xplayer-1.6.0-6.el7 xrootd-4.9.0-2.el7 xviewer-plugins-1.2.0-6.el7 yamllint-1.15.0-2.el7 youtube-dl-2019.01.30-2.el7 yubikey-piv-manager-1.4.2-6.el7 znc-1.7.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ed3564d906

Comment 27 Fedora Update System 2019-03-27 01:40:30 UTC
python-trololio-1.0-2.el7, python-typing-3.5.2.2-4.el7, python-unidiff-0.5.4-2.el7, python-vcstools-0.1.40-2.el7, python-vxi11-0.9-2.el7, python-wcwidth-0.1.7-3.el7, python-whoosh-2.7.4-4.el7, python-wrapt-1.10.4-8.el7, python-www-authenticate-0.9.2-4.el7, python-xapp-1.0.1-9.el7, python-xlrd-1.0.0-7.el7, python-yamlordereddictloader-0.4.0-2.el7, python-yara-3.8.1-2.el7.1, python-zope-component-4.1.0-5.el7, python-zope-configuration-4.0.3-13.el7, python-zope-exceptions-4.0.5-6.el7, python-zope-i18nmessageid-4.0.3-4.el7, python-zope-schema-4.4.1-4.el7, python-zope-testing-4.6.1-8.el7, python3-rpm-4.11.3-3.el7, pyxdg-0.25-7.el7, qpid-proton-0.26.0-2.el7, rlwrap-0.43-2.el7, root-6.16.00-4.el7, sasutils-0.3.9-2.el7, scapy-2.4.0-3.el7, shiboken-1.2.4-10.el7, spglib-1.11.1-2.el7, urjtag-2017.10-3.el7, uwsgi-2.0.17.1-2.el7, xapps-1.0.4-14.el7, xed-1.6.2-3.el7, xplayer-1.6.0-6.el7, xrootd-4.9.0-2.el7, xviewer-plugins-1.2.0-6.el7, yamllint-1.15.0-2.el7, youtube-dl-2019.01.30-2.el7, yubikey-piv-manager-1.4.2-6.el7, znc-1.7.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-ed3564d906

Comment 28 Fedora Update System 2019-04-03 18:50:53 UTC
python-trololio-1.0-2.el7, python-typing-3.5.2.2-4.el7, python-unidiff-0.5.4-2.el7, python-vcstools-0.1.40-2.el7, python-vxi11-0.9-2.el7, python-wcwidth-0.1.7-3.el7, python-whoosh-2.7.4-4.el7, python-wrapt-1.10.4-8.el7, python-www-authenticate-0.9.2-4.el7, python-xapp-1.0.1-9.el7, python-xlrd-1.0.0-7.el7, python-yamlordereddictloader-0.4.0-2.el7, python-yara-3.8.1-2.el7.1, python-zope-component-4.1.0-5.el7, python-zope-configuration-4.0.3-13.el7, python-zope-exceptions-4.0.5-6.el7, python-zope-i18nmessageid-4.0.3-4.el7, python-zope-schema-4.4.1-4.el7, python-zope-testing-4.6.1-8.el7, python3-rpm-4.11.3-3.el7, pyxdg-0.25-7.el7, qpid-proton-0.26.0-2.el7, rlwrap-0.43-2.el7, root-6.16.00-4.el7, sasutils-0.3.9-2.el7, scapy-2.4.0-3.el7, shiboken-1.2.4-10.el7, spglib-1.11.1-2.el7, urjtag-2017.10-3.el7, uwsgi-2.0.17.1-2.el7, xapps-1.0.4-14.el7, xed-1.6.2-3.el7, xplayer-1.6.0-6.el7, xrootd-4.9.0-2.el7, xviewer-plugins-1.2.0-6.el7, yamllint-1.15.0-2.el7, youtube-dl-2019.01.30-2.el7, yubikey-piv-manager-1.4.2-6.el7, znc-1.7.2-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.