Bug 1667491 - Update to jhead 3.03
Summary: Update to jhead 3.03
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: jhead
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Adrian Reber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-18 15:54 UTC by Alejandro Ochoa
Modified: 2019-02-05 03:07 UTC (History)
1 user (show)

Fixed In Version: jhead-3.03-1.fc28 jhead-3.03-1.fc29 jhead-3.03-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-05 01:54:24 UTC


Attachments (Terms of Use)
An image that triggers the bug (5.13 MB, image/jpeg)
2019-01-18 15:54 UTC, Alejandro Ochoa
no flags Details

Description Alejandro Ochoa 2019-01-18 15:54:27 UTC
Created attachment 1521568 [details]
An image that triggers the bug

Description of problem:
Current jhead in Fedora 29 (3.02) damages certain images of mine (details below).  The bug was described and fixed in the latest version (3.03) available on http://www.sentex.net/~mwandel/jhead/ , but this version is not available on Fedora as an RPM yet.  I downloaded and compiled the source and ran on my images, verifying that the problem I experienced is solved in 3.03.

Version-Release number of selected component (if applicable):
3.02

How reproducible:
Always

Steps to Reproduce:
1. Select a digital image (sample IMG_0010.JPG attached) taken on portait mode but which is encoded internally as landscape (on the Canon EOS Rebel T3i and also my cell phone Samsung S7 Edge, problem is likely very broadly present on most digital images).
2. Rotate the image (change internal encoding) with this command:
      jhead -autorot IMG_0010.JPG

Actual results:
  jhead emits this error message: 
      Error : Could not read thumbnail file
      in file 'IMG_0010.JPG'
  Also some junk files appear that didn't use to be created: IMG_0010.JPG.thi and IMG_0010.JPG.tho .
  Lastly, the image IMG_0010.JPG is modified with all EXIF metadata lost, which is what irked me the most.

Expected results:
  No error messages, no junk files, the image IMG_0010.JPG is rotated properly and EXIF metadata is preserved.

Additional info:

Comment 1 Fedora Update System 2019-01-19 11:19:35 UTC
jhead-3.03-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e80c95ac61

Comment 2 Fedora Update System 2019-01-19 11:19:51 UTC
jhead-3.03-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7a4a3fe22f

Comment 3 Fedora Update System 2019-01-19 11:20:13 UTC
jhead-3.03-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-3a35e669e8

Comment 4 Fedora Update System 2019-01-20 00:58:30 UTC
jhead-3.03-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7a4a3fe22f

Comment 5 Fedora Update System 2019-01-20 02:33:56 UTC
jhead-3.03-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e80c95ac61

Comment 6 Fedora Update System 2019-01-20 02:42:23 UTC
jhead-3.03-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-3a35e669e8

Comment 7 Alejandro Ochoa 2019-01-24 13:53:55 UTC
I installed the Fedora 28 testing repository version and tested it on several images.  My bug has been eliminated and everything seems to be working perfectly as far as I can tell.
Thank you!

Comment 8 Adrian Reber 2019-01-24 13:58:01 UTC
Thanks for the feedback. Will push it to stable in about a week.

Comment 9 Fedora Update System 2019-02-05 01:54:24 UTC
jhead-3.03-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2019-02-05 02:17:17 UTC
jhead-3.03-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-02-05 03:07:35 UTC
jhead-3.03-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.