Bug 1667554 - Importing nodes before importing images results in error and traceback.
Summary: Importing nodes before importing images results in error and traceback.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: beta
: 15.0 (Stein)
Assignee: Dmitry Tantsur
QA Contact: Alistair Tonner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-18 19:34 UTC by Alexander Chuzhoy
Modified: 2019-09-26 10:47 UTC (History)
6 users (show)

Fixed In Version: python-tripleoclient-11.4.1-0.20190503200354.0a85020.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:19:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1824329 0 None None None 2019-04-11 11:07:25 UTC
OpenStack gerrit 651753 0 None MERGED Do not log tracebacks for expected exceptions 2020-02-04 10:56:19 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:20:16 UTC

Description Alexander Chuzhoy 2019-01-18 19:34:00 UTC
Importing nodes before importing images results in error and traceback.

Environment:
puppet-ironic-14.2.0-0.20190115174142.b1d4930.el7.noarch
python2-ironic-lib-2.16.0-0.20181018091317.dd7e1fe.el7.noarch
python2-ironicclient-2.5.0-0.20181109051911.fb94fb8.el7.noarch
openstack-ironic-inspector-8.1.1-0.20190108145312.9a8cb3a.el7.noarch


Steps to reproduce:
1. Deploy undercloud
2. Try to import nodes before importing images


Result:
(undercloud) [stack@undercloud ~]$ openstack overcloud node import instackenv.json 
Waiting for messages on queue 'tripleo' with no timeout.
openstack baremetal Kernel image not found in Glance, and no path specified.
Exception occured while running the command
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/command.py", line 28, in run
    super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/cliff/command.py", line 184, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_node.py", line 284, in take_action
    instance_boot_option=parsed_args.instance_boot_option
  File "/usr/lib/python3.6/site-packages/tripleoclient/workflows/baremetal.py", line 80, in register_or_update
    'Exception registering nodes: {}'.format(payload['message']))
tripleoclient.exceptions.RegisterOrUpdateError: Exception registering nodes: Kernel image not found in Glance, and no path specified.
Exception registering nodes: Kernel image not found in Glance, and no path specified.

Expected result:
A message stating that the images aren't found. No traceback.

Comment 1 Dmitry Tantsur 2019-04-11 10:58:18 UTC
Hmm, I wonder if it's a regression in openstackclient. Previously it would only show traceback in --debug mode.

Comment 7 Alistair Tonner 2019-07-17 16:44:40 UTC
core_puddle_version: RHOS_TRUNK-15.0-RHEL-8-20190716.n.0

python3-tripleo-common.noarch                     10.8.1-0.20190710191707.b6a2d65.el8ost                   @rhelosp-15.0-trunk
python3-tripleoclient.noarch                      11.4.1-0.20190705110410.14ae053.el8ost                   @rhelosp-15.0-trunk
python3-tripleoclient-heat-installer.noarch       11.4.1-0.20190705110410.14ae053.el8ost                   @rhelosp-15.0-trunk

Comment 9 errata-xmlrpc 2019-09-21 11:19:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.