Bug 166756 - Broken configure script
Broken configure script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: graphviz (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Ellson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-25 07:50 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: graphviz-2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-04 08:42:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix configure.ac (657 bytes, text/plain)
2005-08-25 07:50 EDT, Ralf Corsepius
no flags Details

  None (edit)
Description Ralf Corsepius 2005-08-25 07:50:45 EDT
Description of problem:
graphviz's configure.ac mis-applies canonicalization. The authors mix up $target
and $host (cf. info autoconf). Where $host should be used, they use $target.
This causes autoconf to apply "seemingly broken" transform rules.
(The rules autoconf generates are correct, the configure script however is broken).

This is the cause for graphviz.spec having to work-around these bugs by
overriding transform during 'make install'

Version-Release number of selected component (if applicable):
graphviz-2.2.1


Additional info:
graphviz-2.4.x (rawhide) suffers from the same issue.
Comment 1 Ralf Corsepius 2005-08-25 07:50:45 EDT
Created attachment 118106 [details]
Patch to fix configure.ac
Comment 2 Oliver Falk 2005-08-25 07:55:04 EDT
Thanks a lot Ralf. I will let John know about this!
Comment 3 John Ellson 2005-10-18 08:01:12 EDT
Already fixed in graphviz-2.6.

Note You need to log in before you can comment on or make changes to this bug.