Bug 1667641 - Provide builds for Python3 and update to 0.8.x versions [NEEDINFO]
Summary: Provide builds for Python3 and update to 0.8.x versions
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-tabulate
Version: epel7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1659777
TreeView+ depends on / blocked
 
Reported: 2019-01-19 09:27 UTC by Raphael Groner
Modified: 2019-04-16 16:49 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-03-29 18:56:41 UTC
projects.rg: needinfo? (pnemade)


Attachments (Terms of Use)

Description Raphael Groner 2019-01-19 09:27:17 UTC
Description of problem:
EPEL7 has a package for python2 only. Please provide updates for python34 (3.4) and 36 (3.6) as those currently available versions of Python.

Version-Release number of selected component (if applicable):
-

How reproducible:
yes

Steps to Reproduce:
1. dnf install python34-tabulate
2. dnf install python36-tabulate
3.

Actual results:
error: no packages found.

Expected results:
packages install properly.

Additional info:
We'll need at least python34, esp. for python-vconnector (bug #1659777).

Comment 1 Igor Gnatenko 2019-01-19 09:33:31 UTC
I guess I should report a bug that when I send "never send me mails about this bug", it still sends me a n email... =(

Comment 2 Raphael Groner 2019-01-19 10:20:34 UTC
Maybe use python-docopt as a template.
https://src.fedoraproject.org/rpms/python-docopt/c/5c8f7f1a401dc65a4cef462a582ec06fdd4d616e?branch=master

Comment 3 Raphael Groner 2019-01-19 10:21:16 UTC
(In reply to Igor Gnatenko from comment #1)
> I guess I should report a bug that when I send "never send me mails about
> this bug", it still sends me a n email... =(

Oh sorry, I see Ralph as the responsible person, so I wrongly guessed.
Can you add me as co-maintainer then?

Comment 4 Raphael Groner 2019-01-25 22:27:31 UTC
Any news here?

Comment 5 Raphael Groner 2019-01-25 22:42:39 UTC
python-tabulate is indirectly also needed to package pvc [1] and py-vpoller [2] in epel. Therefore, it would be nice to have someone responsible for the branches.

[1] https://github.com/dnaeon/pvc
[2] https://github.com/dnaeon/py-vpoller

Comment 6 Ralph Bean 2019-01-26 15:18:04 UTC
Adding you as a co-maintainer Raphael.  Sorry for the delay.

Comment 7 Raphael Groner 2019-02-14 20:29:21 UTC
Thanks, I'm going to merge from rawhide (master branch) and readd lost python2 build for epel7 only.

There seems to be one dependency only in epel7: transtats-cli
Getting the maintainer in the boat. As far as I can see, the tests use python-tabulate and work in recent rawhide build with version 0.8.3, that let's assume a success in epel7 as well where we've the same version of transtats-cli. Please let me know if you see any issue. Maybe you can then add a build for python3 of transtats-cli as well in epel7.
https://koji.fedoraproject.org/koji/buildinfo?buildID=1204184

Comment 8 Raphael Groner 2019-02-21 13:50:14 UTC
Another friendly ping. What's the state for comment #7?

Comment 9 Parag Nemade 2019-02-21 14:23:29 UTC
Raphael,

How can I help here?

Comment 10 Raphael Groner 2019-02-21 18:20:04 UTC
(In reply to Parag Nemade from comment #9)
> Raphael,
> 
> How can I help here?

As I've already the needed power, I can do the update as described below.

Comment 11 Raphael Groner 2019-02-21 19:41:56 UTC
python34-tabulate needs python34-pandas needs python34-matplotlib needs ...:

https://src.fedoraproject.org/rpms/python-pandas/pull-request/2

Comment 12 Raphael Groner 2019-02-24 22:44:35 UTC
Managed to build without python34-pandas.

Comment 13 Fedora Update System 2019-02-24 22:49:52 UTC
python-tabulate-0.8.3-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-152d3f7145

Comment 14 Fedora Update System 2019-02-25 01:52:15 UTC
python-tabulate-0.8.3-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-152d3f7145

Comment 15 Raphael Groner 2019-02-25 06:08:56 UTC
Maintainer of transtats-cli, can you please check if all is still going well with the new version of transtats-cli?

Comment 16 Fedora Update System 2019-03-29 18:56:41 UTC
python-tabulate-0.8.3-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.