Bug 1667681 - crash selecting clip; patch upstream
Summary: crash selecting clip; patch upstream
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-sound-recorder
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1650932 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-19 19:17 UTC by Brian J. Murrell
Modified: 2019-01-22 17:42 UTC (History)
3 users (show)

Fixed In Version: gnome-sound-recorder-3.28.2-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-22 17:42:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Brian J. Murrell 2019-01-19 19:17:33 UTC
Description of problem:
I hit this crasher: https://gitlab.gnome.org/GNOME/gnome-sound-recorder/issues/44 trying to select a clip.

Version-Release number of selected component (if applicable):
gnome-sound-recorder-3.28.1-4.fc29.noarch

How reproducible:
100%

I see that a 3.28.2 release is being prepared at https://src.fedoraproject.org/rpms/gnome-sound-recorder/commits/f29

But it looks like there is a bugfix ahead of 3.28.2 that might fix this:

https://gitlab.gnome.org/GNOME/gnome-sound-recorder/commit/2b311ef67909bc20d0e87f334fe37bf5c4e9f29f

Given that this fix is on the gnome-3-28 branch of gnome-sound-recorder:
https://gitlab.gnome.org/GNOME/gnome-sound-recorder/commits/gnome-3-28

Can we have the Fedora 3.28.2 RPM above include this patch please?

Comment 1 Brian J. Murrell 2019-01-19 19:39:00 UTC
I can confirm through a local build of the above RPM update with the above patch applied that the patch does fix the crash.

Strongly recommend adding it to the 3.28.2 RPM before releasing it.

Comment 2 Fedora Update System 2019-01-20 19:20:34 UTC
gnome-sound-recorder-3.28.2-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-11a23bc4f0

Comment 3 Fedora Update System 2019-01-21 02:31:36 UTC
gnome-sound-recorder-3.28.2-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-11a23bc4f0

Comment 4 Brian J. Murrell 2019-01-21 03:38:36 UTC
Cheers

Comment 5 David King 2019-01-21 07:40:16 UTC
*** Bug 1650932 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2019-01-22 17:42:23 UTC
gnome-sound-recorder-3.28.2-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.