Bug 166784 - Installer hangs loading cciss unless acpi=off
Installer hangs loading cciss unless acpi=off
Status: CLOSED DUPLICATE of bug 164608
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-25 14:00 EDT by Dan Franklin
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 01:50:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Franklin 2005-08-25 14:00:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
FC4 rescue CD hangs at "loading CCISS driver" screen.  FC3 did not have this problem.
Hardware is 2-processor Compaq DL 380 G2 with HP Smart Array 5i RAID.




Version-Release number of selected component (if applicable):
kernel 2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot from FC4 rescue CD.
2. Type "linux" at boot prompt.

  

Actual Results:  It hangs at the "loading CCISS driver" screen.

Expected Results:  It should have continued on.

Additional info:

The log shows the CCISS driver changed revisions from HP CISS 2.6.2 to 2.6.6; the new driver logs the following:

<6>HP CISS Driver (v 2.6.6)
<7>cciss: Device 0xb178 has been found at bus 0 dev 1 func 0
<4>ACPI: PCI Interrupt Link [INA0]  enabled at IRQ 15
<4>ACPI: PCI Interrupt 0000:00:01.0[A] -> Link [INA0] -> GSI 15 (level, lopw) -> IRQ 15
<4>cciss: using DAC cycles
<6>    blocks= 574612920 block_size= 512
<6>    heads= 255, sectors= 63, cylinders= 35768
<4>

and stops.  The old driver does not log any ACPI activity, and follows the lines above with a successful identification of the RAID partitions:

<6> cciss/c0d0: p1 p2 p3

and continues.

If I start the rescue CD with "linux acpi=off" it works fine.
Comment 1 Dave Jones 2005-08-26 19:45:52 EDT
I assume you've now installed with acpi=off
Can you verify that the current errata kernel in updates-testing works or not
with out the acpi=off ?

That kernel contains an acpi update, which may fix your problem.
Comment 2 Dan Franklin 2005-08-31 23:10:56 EDT
It still happens with 2.6.12-1.1447_FC4. (Is that the latest one? It's from
updates-released.  There does not seem to be a more recent kernel in
updates-testing at this time.)
Comment 3 Dave Jones 2005-09-30 01:50:33 EDT

*** This bug has been marked as a duplicate of 164608 ***

Note You need to log in before you can comment on or make changes to this bug.