Bug 1667905 - dict_leak in __glusterd_handle_cli_uuid_get function
Summary: dict_leak in __glusterd_handle_cli_uuid_get function
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-21 11:56 UTC by Mohit Agrawal
Modified: 2019-03-25 16:33 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-22 05:14:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22069 None Merged glusterd: Avoid dict_leak in __glusterd_handle_cli_uuid_get function 2019-01-22 05:14:54 UTC

Description Mohit Agrawal 2019-01-21 11:56:06 UTC
Description of problem:
dict_leak in __glusterd_handle_cli_uuid_get function

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-01-22 05:14:56 UTC
REVIEW: https://review.gluster.org/22069 (glusterd: Avoid dict_leak in __glusterd_handle_cli_uuid_get function) merged (#3) on master by Amar Tumballi

Comment 2 Shyamsundar 2019-03-25 16:33:07 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.