Bug 1668029 (PYFLAGS) - Avoid Fedora-specific build flags in non-RPM Python extensions
Summary: Avoid Fedora-specific build flags in non-RPM Python extensions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: PYFLAGS
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact:
URL:
Whiteboard:
: 1217376 (view as bug list)
Depends On:
Blocks: Fedora28BuildFlags 1548822 1548823
TreeView+ depends on / blocked
 
Reported: 2019-01-21 17:56 UTC by Ben Cotton
Modified: 2019-05-21 11:55 UTC (History)
3 users (show)

Fixed In Version: python3-3.7.2-6.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-21 11:55:20 UTC
Type: ---


Attachments (Terms of Use)

Description Ben Cotton 2019-01-21 17:56:11 UTC
This is a tracking bug for Change: Avoid Fedora-specific build flags in non-RPM Python extensions
For more details, see: https://fedoraproject.org/wiki/Changes/Python_Extension_Flags

The build flags (CFLAGS, CXXFLAGS and LDFLAGS) saved in the Python's distutils module for building extension modules are switched from:

Comment 1 Miro Hrončok 2019-01-21 22:19:54 UTC
*** Bug 1217376 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2019-02-13 08:49:03 UTC
All packages that explicitly called "python3 setup.py build/build_ext" without proper flags are fixed now. We will proceed with Python itself this week.

Comment 5 Miro Hrončok 2019-02-14 18:10:18 UTC
Python is adjusted.


Note You need to log in before you can comment on or make changes to this bug.