Bug 1668200 - Search Gateway: "Unknown resource: gatewaies/networking.istio.io/v1alpha3"
Summary: Search Gateway: "Unknown resource: gatewaies/networking.istio.io/v1alpha3"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-22 08:05 UTC by Javier Ramirez
Modified: 2019-06-04 10:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, listing Istio Gateway resources in the web console Other Resources view would cause an error. This has been fixed in the 4.0 console, where the Home -> Search view correctly shows the list of Gateway resources.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
searchlist (196.43 KB, image/png)
2019-01-29 06:01 UTC, Yanping Zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:13 UTC
Github openshift origin issues 21202 None None None 2019-01-22 08:06:31 UTC

Description Javier Ramirez 2019-01-22 08:05:19 UTC
Description of problem:
When searching for "Gateway" in Resources -> Other Resources, Error is shown:
"Unknown resource: gatewaies/networking.istio.io/v1alpha3"

Version-Release number of selected component (if applicable):
OpenShift Master: v3.10.14
Kubernetes Master: v1.10.0+b81c8f8
OpenShift Web Console: v3.10.14


How reproducible:
Always

Steps to Reproduce:
1. Go to "Resources" -> "Other Resources"
2. Search for "Gateway"


Actual results:
Error Notification is shown.
No Gateways listed. Search result is "No ."


Expected results:
Should list Gateways or empty list.

Additional info:

Comment 1 Samuel Padgett 2019-01-22 14:57:05 UTC
Ideally we should avoid using kindToResource and just use the resource returned from API discovery.

Comment 2 Samuel Padgett 2019-01-22 15:03:48 UTC
This is fixed in the 4.0 console.

Comment 3 Samuel Padgett 2019-01-23 12:47:06 UTC
https://github.com/openshift/console/pull/263

Comment 5 Yanping Zhang 2019-01-29 06:00:48 UTC
registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-28-212509@sha256   40c1d5bad78f9f98331a66c8aee098ad93bf295c245bd0501be1c6118c98cadd   40e6659c2417   12 hours ago    269 MB
console repo commit id: 3c3e54803fa9a223b1f4e817cc2c710e000414df
Checked on Search page, not all the resources items have apiversion added in dropdown list, pls refer to attachment.

Comment 6 Yanping Zhang 2019-01-29 06:01:27 UTC
Created attachment 1524469 [details]
searchlist

Comment 7 Samuel Padgett 2019-01-29 19:17:58 UTC
This is expected. We only show api group when the same resource appears in more than one api group to avoid clutter.

Comment 8 Yanping Zhang 2019-01-30 03:27:31 UTC
According to Comment 5 and Comment 7, the bug has been fixed, now only show api group when the same resource appears in more than one api group.

Comment 11 errata-xmlrpc 2019-06-04 10:42:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.