Bug 1668248 - "An unknown error has occurred" when using cdrom to install the system with two blockdev disks.(when choose installation destination)
Summary: "An unknown error has occurred" when using cdrom to install the system with t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux Advanced Virtualization
Classification: Red Hat
Component: qemu-kvm
Version: 8.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 8.0
Assignee: Kevin Wolf
QA Contact: Xueqiang Wei
URL:
Whiteboard:
Depends On:
Blocks: 1668538 1673080
TreeView+ depends on / blocked
 
Reported: 2019-01-22 09:57 UTC by zhenyzha
Modified: 2019-11-12 00:14 UTC (History)
19 users (show)

Fixed In Version: qemu-kvm-3.1.0-12.module+el8+2778+279c3c9e
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1668538 1673080 (view as bug list)
Environment:
Last Closed: 2019-05-29 16:05:29 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
error message picture (347.08 KB, image/png)
2019-01-22 09:57 UTC, zhenyzha
no flags Details
./tmp/anaconda.log (21.34 KB, application/octet-stream)
2019-01-22 10:05 UTC, zhenyzha
no flags Details
With virtio-blk-pci parameter the system can be installed normally (354.19 KB, image/png)
2019-01-22 14:06 UTC, zhenyzha
no flags Details
anaconda exception screenshot 1 (123.02 KB, image/png)
2019-01-23 08:13 UTC, Xueqiang Wei
no flags Details
anaconda exception screenshot 2 (113.89 KB, image/png)
2019-01-23 08:13 UTC, Xueqiang Wei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1293 None None None 2019-05-29 16:05:53 UTC

Description zhenyzha 2019-01-22 09:57:42 UTC
Created attachment 1522357 [details]
error message picture

Description of problem:
When using cdrom to install the system, there are two blockdev disks.choose installation destination,show error message:An unknown error has occurred

Version-Release number of selected component (if applicable):
  kernel version:4.18.0-62.el8.ppc64le
  qemu-kvm version:qemu-kvm-3.1.0-5.module+el8+2708+fbd828c6


How reproducible:
5/5

Steps to Reproduce:
/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-sandbox off \
-machine pseries \
-m 8G \
-nodefaults \
-vga std \
-device nec-usb-xhci,id=xhci \
-device usb-tablet,id=usb-tablet0 \
-device usb-kbd,id=usb-kbd0 \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x06,id=scsi-pci-0 \
-netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup \
-device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=40:f2:e9:5d:9c:07 \
-cdrom /mnt/os/RHEL-8.0-20190116.1-ppc64le-dvd1.iso \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=guest.qcow2,node-name=my_file \
-blockdev driver=qcow2,node-name=my,file=my_file \
-device scsi-hd,drive=my,bus=scsi-pci-0.0,id=zhneg \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/test/zhenyzha-nfs/disk/disk_6,node-name=disk_0 \
-blockdev driver=qcow2,node-name=my0,file=disk_0 \
-device scsi-hd,id=target0,drive=my0,bus=scsi-pci-0.0 \


Actual results:
show error message:An unknown error has occurred

Expected results:
Normal installation

Additional info:
Use the -drive parameter no problem.
I will verify this issue again on X86.

The above problem will also occur with the following version:
kernel version:4.18.0-62.el8.ppc64le
qemu-kvm version:qemu-kvm-3.1.0-4.module

Comment 1 zhenyzha 2019-01-22 10:05:19 UTC
Created attachment 1522359 [details]
./tmp/anaconda.log

Comment 2 zhenyzha 2019-01-22 10:34:32 UTC
Use the scsi-cd parameter,the problem still exists.

/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-sandbox off \
-machine pseries \
-m 8G \
-nodefaults \
-vga std \
-device nec-usb-xhci,id=xhci \
-device usb-tablet,id=usb-tablet0 \
-device usb-kbd,id=usb-kbd0 \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x06,id=scsi-pci-0 \
-netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup \
-device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=40:f2:e9:5d:9c:07 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-ppc64le-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=guest.qcow2,node-name=my_file \
-blockdev driver=qcow2,node-name=my,file=my_file \
-device scsi-hd,drive=my,bus=scsi-pci-0.0,id=zhneg \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/test/zhenyzha-nfs/disk/disk_6,node-name=disk_0 \
-blockdev driver=qcow2,node-name=my0,file=disk_0 \
-device scsi-hd,id=target0,drive=my0,bus=scsi-pci-0.0 \

Comment 3 zhenyzha 2019-01-22 14:01:36 UTC
Use the virtio-blk-pci parameter,the system can be installed normally.

/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-sandbox off \
-machine pseries \
-m 8G \
-nodefaults \
-vga std \
-device nec-usb-xhci,id=xhci \
-device usb-tablet,id=usb-tablet0 \
-device usb-kbd,id=usb-kbd0 \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup \
-device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=40:f2:e9:5d:9c:07 \
-device virtio-scsi-pci,bus=pci.0,addr=0x06,id=scsi-pci-0 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-ppc64le-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio0-0-1,id=virtio0-0-1 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/test/zhenyzha-nfs/disk/disk_6,node-name=disk_0 \
-blockdev driver=qcow2,node-name=drive-virtio0-0-1,file=disk_0 \
-device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio0-0-2,id=virtio0-0-2 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=guest.qcow2,node-name=disk_1 \
-blockdev driver=qcow2,node-name=drive-virtio0-0-2,file=disk_1 \

Comment 4 zhenyzha 2019-01-22 14:06:27 UTC
Created attachment 1522426 [details]
With virtio-blk-pci parameter the system can be installed normally

Comment 6 Qunfang Zhang 2019-01-23 01:06:22 UTC
Zhenyu, Please update "Hardware" field after you tried same steps on x86 host. Thanks.

Comment 7 zhenyzha 2019-01-23 02:54:18 UTC
(In reply to Qunfang Zhang from comment #6)

This issue still exists on x86

/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-m 4G \
-nodefaults \
-vga qxl \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x05,id=scsi-pci-1 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-x86_64-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6 \
-device virtio-scsi-pci,id=scsi-pci-0,bus=pcie.0-root-port-6,addr=0x0 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=guest.qcow2,node-name=my_file \
-blockdev driver=qcow2,node-name=my,file=my_file \
-device scsi-hd,drive=my,bus=scsi-pci-0.0,id=zhneg \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/test/zhenyzha-nfs/disk/disk_6,node-name=disk_0 \
-blockdev driver=qcow2,node-name=my0,file=disk_0 \
-device scsi-hd,drive=my0,bus=scsi-pci-0.0,id=target0 \
> Zhenyu, Please update "Hardware" field after you tried same steps on x86
> host. Thanks.

Comment 8 zhenyzha 2019-01-23 03:01:28 UTC
The X86 Version-Release number of selected component (if applicable):
  kernel version:4.18.0-62.el8.x86_64
  qemu-kvm version:qemu-kvm-3.1.0-5.module+el8+2708+fbd828c6

Comment 9 Xueqiang Wei 2019-01-23 08:09:43 UTC
Test on x86 platform with below cmd lines, hit this issue. Click "More info" in GUI, prompt "anaconda 29.19.0.32 exception report...", please refer to attached screenshot.


kernel-4.18.0-63.el8.x86_64
qemu-kvm-3.1.0-5.module+el8+2708+fbd828c6


/usr/libexec/qemu-kvm \
    -S  \
    -name 'avocado-vt-vm1' \
    -machine q35  \
    -nodefaults \
    -device VGA,bus=pcie.0,addr=0x1 \
    -device pcie-root-port,id=pcie_root_port_0,slot=2,chassis=2,addr=0x2,bus=pcie.0 \
    -device pcie-root-port,id=pcie_root_port_1,slot=3,chassis=3,addr=0x3,bus=pcie.0 \
    -device pcie-root-port,id=pcie_root_port_2,slot=4,chassis=4,addr=0x4,bus=pcie.0  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_kww01fp9/monitor-qmpmonitor1-20190123-022244-PPCvMk0N,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_kww01fp9/monitor-catch_monitor-20190123-022244-PPCvMk0N,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idKWHdZy  \
    -chardev socket,id=serial_id_serial0,path=/var/tmp/avocado_kww01fp9/serial-serial0-20190123-022244-PPCvMk0N,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20190123-022244-PPCvMk0N,path=/var/tmp/avocado_kww01fp9/seabios-20190123-022244-PPCvMk0N,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20190123-022244-PPCvMk0N,iobase=0x402 \
    -device pcie-root-port,id=pcie.0-root-port-5,slot=5,chassis=5,addr=0x5,bus=pcie.0 \
    -device qemu-xhci,id=usb1,bus=pcie.0-root-port-5,addr=0x0 \
    -device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pcie.0-root-port-6,addr=0x0 \
    -blockdev node-name=file_image1,driver=file,cache.direct=on,cache.no-flush=off,filename=/home/kvm_autotest_root/images/rhel80-64-virtio-scsi-install-test.qcow2,aio=threads \
    -blockdev node-name=drive_image1,driver=qcow2,cache.direct=on,cache.no-flush=off,file=file_image1 \
    -device scsi-hd,id=image1,drive=drive_image1,write-cache=on,bus=virtio_scsi_pci0.0 \
    -blockdev driver=file,cache.direct=on,cache.no-flush=off,filename=/home/kvm_autotest_root/images/data.raw,node-name=data_disk \
    -blockdev driver=raw,node-name=disk1,file=data_disk,cache.direct=on,cache.no-flush=off \
    -device scsi-hd,drive=disk1,id=data_disk,write-cache=on,bus=virtio_scsi_pci0.0 \
    -device pcie-root-port,id=pcie.0-root-port-7,slot=7,chassis=7,addr=0x7,bus=pcie.0 \
    -device virtio-net-pci,mac=9a:63:64:65:66:67,id=idDQ4Oke,vectors=4,netdev=idaNEvdg,bus=pcie.0-root-port-7,addr=0x0  \
    -netdev tap,id=idaNEvdg,vhost=on \
    -m 18432  \
    -smp 12,maxcpus=12,cores=6,threads=1,sockets=2  \
    -cpu 'SandyBridge',+kvm_pv_unhalt \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -monitor stdio \
    -device pcie-root-port,id=pcie.0-root-port-10,slot=10,chassis=10,addr=0x10,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci2,bus=pcie.0-root-port-10,addr=0x0 \
    -blockdev driver=file,cache.direct=on,cache.no-flush=off,filename=/home/kvm_autotest_root/iso/linux/RHEL-8.0-20190116.1-x86_64-dvd1.iso,node-name=cd_disk1,read-only=on \
    -blockdev driver=raw,node-name=cd1,file=cd_disk1,read-only=on,cache.direct=on,cache.no-flush=off \
    -device scsi-cd,drive=cd1,bus=virtio_scsi_pci2.0,id=cd_disk1,write-cache=on \

Comment 10 Xueqiang Wei 2019-01-23 08:13:00 UTC
Created attachment 1522595 [details]
anaconda exception screenshot 1

Comment 11 Xueqiang Wei 2019-01-23 08:13:24 UTC
Created attachment 1522596 [details]
anaconda exception screenshot 2

Comment 12 xianwang 2019-01-23 08:22:01 UTC
Issue is hit on RHEL-8.0-20181220.1-ppc64le-dvd1.iso, anaconda:29.19.0.29

Host:
4.18.0-63.el8.ppc64le
qemu-kvm-3.1.0-4.module+el8+2676+33bd6e2b.ppc64le

qemu cli is same with comment 2, result is same with bug report.

Comment 13 Kevin Wolf 2019-01-23 11:47:13 UTC
The screenshots look to me as if there is at least an Anaconda bug.

I'm not sure if there might be a QEMU bug, too, because we don't have any information on what the problem really is. But if there is, it doesn't seem to be related to -blockdev, but rather to virtio-scsi. Is this really not reproducible with -drive? What is the -drive based command line you tested?

Comment 14 zhenyzha 2019-01-24 00:47:42 UTC
(In reply to Kevin Wolf from comment #13)
> The screenshots look to me as if there is at least an Anaconda bug.
> 
> I'm not sure if there might be a QEMU bug, too, because we don't have any
> information on what the problem really is. But if there is, it doesn't seem
> to be related to -blockdev, but rather to virtio-scsi. Is this really not
> reproducible with -drive? What is the -drive based command line you tested?


This the -drive command line,It‘s normal:
/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-sandbox off \
-machine pseries \
-m 8G \
-nodefaults \
-vga std \
-device nec-usb-xhci,id=xhci \
-device usb-tablet,id=usb-tablet0 \
-device usb-kbd,id=usb-kbd0 \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x06,id=scsi-pci-0 \
-device virtio-scsi-pci,bus=pci.0,addr=0x07,id=scsi-pci-1 \
-netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup \
-device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=40:f2:e9:5d:9c:07 \
-device virtio-scsi-pci,bus=pci.0,addr=0x05,id=scsi-pci-2 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-ppc64le-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-drive id=my0,format=qcow2,media=disk,if=none,file=/home/test/zhenyzha-nfs/disk/disk0 \
-device scsi-hd,id=target0,drive=my0,bus=scsi-pci-1.0 \
-drive id=my,format=qcow2,media=disk,if=none,file=guest.qcow2 \
-device scsi-hd,id=target1,drive=my,bus=scsi-pci-1.0 \

Comment 15 zhenyzha 2019-01-24 01:32:20 UTC
This on x86 -drive command line,It‘s normal. 

/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-m 4G \
-nodefaults \
-vga qxl \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x05,id=scsi-pci-1 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-x86_64-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6 \
-device virtio-scsi-pci,id=scsi-pci-0,bus=pcie.0-root-port-6,addr=0x0 \
-drive id=my0,format=qcow2,media=disk,if=none,file=/home/test/zhenyzha-nfs/disk/disk_6 \
-device scsi-hd,id=target0,drive=my0,bus=scsi-pci-1.0 \
-drive id=my,format=qcow2,media=disk,if=none,file=guest.qcow2 \
-device scsi-hd,id=target1,drive=my,bus=scsi-pci-1.0 \

In addition with the latest version of qemu-kvm-3.1.0-6.module+el8+2711+98525d2b, -blockdev driver the problem still exists.
/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-m 4G \
-nodefaults \
-vga qxl \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x05,id=scsi-pci-1 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-x86_64-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6 \
-device virtio-scsi-pci,id=scsi-pci-0,bus=pcie.0-root-port-6,addr=0x0 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=guest.qcow2,node-name=my_file \
-blockdev driver=qcow2,node-name=my,file=my_file \
-device scsi-hd,drive=my,bus=scsi-pci-0.0,id=zhneg \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/test/zhenyzha-nfs/disk/disk_6,node-name=disk_0 \
-blockdev driver=qcow2,node-name=my0,file=disk_0 \
-device scsi-hd,drive=my0,bus=scsi-pci-0.0,id=target0 \

Comment 16 Kevin Wolf 2019-01-24 12:27:23 UTC
One difference I see is that you add the disks in a different order in both command lines, so I think the order will be swapped inside the VM, too.

Other differences are missing cache=unsafe in the -drive command line, and scsi-pci-1.0 vs. scsi-pci-0.0 (i.e. the disks sit on the same controller as the CD drive in your -drive command line, but on a separate one in the -blockdev one).

Can you eliminate those differences and still get the different behaviour?

Comment 17 zhenyzha 2019-01-24 13:42:18 UTC
(In reply to Kevin Wolf from comment #16)
> One difference I see is that you add the disks in a different order in both
> command lines, so I think the order will be swapped inside the VM, too.
> 
> Other differences are missing cache=unsafe in the -drive command line, and
> scsi-pci-1.0 vs. scsi-pci-0.0 (i.e. the disks sit on the same controller as
> the CD drive in your -drive command line, but on a separate one in the
> -blockdev one).
> 
> Can you eliminate those differences and still get the different behaviour?

Hi Kevin

Thank you for your replyas,as you wish.
I eliminate those differences and got the different behaviour.

This on x86 -drive command line,It‘s normal with the latest version of qemu-kvm-3.1.0-6.module+el8+2711+98525d2b.
/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-m 4G \
-nodefaults \
-vga qxl \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x05,id=scsi-pci-1 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-x86_64-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6 \
-device virtio-scsi-pci,id=scsi-pci-0,bus=pcie.0-root-port-6,addr=0x0 \
-drive id=my,format=qcow2,media=disk,if=none,cache.direct=off,cache.no-flush=on,file=guest.qcow2 \
-device scsi-hd,id=target0,drive=my,bus=scsi-pci-0.0 \
-drive id=my0,format=qcow2,media=disk,if=none,cache.direct=off,cache.no-flush=on,file=/home/test/zhenyzha-nfs/disk/disk_0 \
-device scsi-hd,id=target1,drive=my0,bus=scsi-pci-0.0 \

This on x86 -blockdev driver command line,the problem still exists with the latest version of qemu-kvm-3.1.0-6.module+el8+2711+98525d2b too.
/usr/libexec/qemu-kvm \
-name zhenyzha-RHEL-8.0-20181220.1 \
-m 4G \
-nodefaults \
-vga qxl \
-smp 4,cores=4,threads=1,sockets=1 \
-vnc :30 \
-monitor stdio \
-rtc base=utc,clock=host \
-boot order=cd,menu=off,strict=off \
-enable-kvm \
-qmp unix:/var/tmp/qmp-monitor-zhenyzha,server,nowait \
-qmp tcp:0:3001,server,nowait \
-device virtio-scsi-pci,bus=pci.0,addr=0x05,id=scsi-pci-1 \
-blockdev driver=raw,file.driver=file,node-name=drive_cd1,cache.no-flush=on,cache.direct=off,file.filename=/mnt/os/RHEL-8.0-20190116.1-x86_64-dvd1.iso,read-only=on \
-device scsi-cd,id=cd1,drive=drive_cd1,bootindex=0 \
-device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6 \
-device virtio-scsi-pci,id=scsi-pci-0,bus=pcie.0-root-port-6,addr=0x0 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=guest.qcow2,node-name=my_file \
-blockdev driver=qcow2,node-name=my,file=my_file \
-device scsi-hd,id=target0,drive=my,bus=scsi-pci-0.0 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/test/zhenyzha-nfs/disk/disk_0,node-name=disk_0 \
-blockdev driver=qcow2,node-name=my0,file=disk_0 \
-device scsi-hd,id=target1,drive=my0,bus=scsi-pci-0.0 \

Comment 18 Xueqiang Wei 2019-01-25 07:40:13 UTC
Set cache=none, add bootindex to each disk and then test with blockdev and drive. Hit this issue with blockdev. With drive, install successfully.


kernel-4.18.0-63.el8.x86_64
qemu-kvm-3.1.0-5.module+el8+2708+fbd828c6


blockdev cmd lines:

/usr/libexec/qemu-kvm \
    -S  \
    -name 'avocado-vt-vm1' \
    -machine q35  \
    -nodefaults \
    -device VGA,bus=pcie.0,addr=0x1 \
    -device pcie-root-port,id=pcie_root_port_0,slot=2,chassis=2,addr=0x2,bus=pcie.0 \
    -device pcie-root-port,id=pcie_root_port_1,slot=3,chassis=3,addr=0x3,bus=pcie.0 \
    -device pcie-root-port,id=pcie_root_port_2,slot=4,chassis=4,addr=0x4,bus=pcie.0  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_kww01fp9/monitor-qmpmonitor1-20190123-022244-PPCvMk0N,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_kww01fp9/monitor-catch_monitor-20190123-022244-PPCvMk0N,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idKWHdZy  \
    -chardev socket,id=serial_id_serial0,path=/var/tmp/avocado_kww01fp9/serial-serial0-20190123-022244-PPCvMk0N,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20190123-022244-PPCvMk0N,path=/var/tmp/avocado_kww01fp9/seabios-20190123-022244-PPCvMk0N,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20190123-022244-PPCvMk0N,iobase=0x402 \
    -device pcie-root-port,id=pcie.0-root-port-5,slot=5,chassis=5,addr=0x5,bus=pcie.0 \
    -device qemu-xhci,id=usb1,bus=pcie.0-root-port-5,addr=0x0 \
    -device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pcie.0-root-port-6,addr=0x0 \
    -blockdev node-name=file_image1,driver=file,cache.direct=on,cache.no-flush=off,filename=/home/kvm_autotest_root/images/rhel80-64-virtio-scsi-install-test.qcow2,aio=threads \
    -blockdev node-name=drive_image1,driver=qcow2,cache.direct=on,cache.no-flush=off,file=file_image1 \
    -device scsi-hd,id=image1,drive=drive_image1,write-cache=on,bus=virtio_scsi_pci0.0,bootindex=1 \
    -blockdev driver=file,cache.direct=on,cache.no-flush=off,filename=/home/kvm_autotest_root/images/data.raw,node-name=data_disk \
    -blockdev driver=raw,node-name=disk1,file=data_disk,cache.direct=on,cache.no-flush=off \
    -device scsi-hd,drive=disk1,id=data_disk,write-cache=on,bus=virtio_scsi_pci0.0,bootindex=2 \
    -device pcie-root-port,id=pcie.0-root-port-7,slot=7,chassis=7,addr=0x7,bus=pcie.0 \
    -device virtio-net-pci,mac=9a:63:64:65:66:67,id=idDQ4Oke,vectors=4,netdev=idaNEvdg,bus=pcie.0-root-port-7,addr=0x0  \
    -netdev tap,id=idaNEvdg,vhost=on \
    -m 18432  \
    -smp 12,maxcpus=12,cores=6,threads=1,sockets=2  \
    -cpu 'SandyBridge',+kvm_pv_unhalt \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -monitor stdio \
    -device pcie-root-port,id=pcie.0-root-port-10,slot=10,chassis=10,addr=0x10,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci2,bus=pcie.0-root-port-10,addr=0x0 \
    -blockdev driver=file,cache.direct=on,cache.no-flush=off,filename=/home/kvm_autotest_root/iso/linux/RHEL-8.0-20190116.1-x86_64-dvd1.iso,node-name=cd_disk1,read-only=on \
    -blockdev driver=raw,node-name=cd1,file=cd_disk1,read-only=on,cache.direct=on,cache.no-flush=off \
    -device scsi-cd,drive=cd1,bus=virtio_scsi_pci2.0,id=cd_disk1,write-cache=on,bootindex=0 \




Drive cmd lines:

/usr/libexec/qemu-kvm \
    -S  \
    -name 'avocado-vt-vm1' \
    -machine q35  \
    -nodefaults \
    -device VGA,bus=pcie.0,addr=0x1 \
    -device pcie-root-port,id=pcie_root_port_0,slot=2,chassis=2,addr=0x2,bus=pcie.0 \
    -device pcie-root-port,id=pcie_root_port_1,slot=3,chassis=3,addr=0x3,bus=pcie.0 \
    -device pcie-root-port,id=pcie_root_port_2,slot=4,chassis=4,addr=0x4,bus=pcie.0  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_kww01fp9/monitor-qmpmonitor1-20190123-022244-PPCvMk0N,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_kww01fp9/monitor-catch_monitor-20190123-022244-PPCvMk0N,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idKWHdZy  \
    -chardev socket,id=serial_id_serial0,path=/var/tmp/avocado_kww01fp9/serial-serial0-20190123-022244-PPCvMk0N,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20190123-022244-PPCvMk0N,path=/var/tmp/avocado_kww01fp9/seabios-20190123-022244-PPCvMk0N,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20190123-022244-PPCvMk0N,iobase=0x402 \
    -device pcie-root-port,id=pcie.0-root-port-5,slot=5,chassis=5,addr=0x5,bus=pcie.0 \
    -device qemu-xhci,id=usb1,bus=pcie.0-root-port-5,addr=0x0 \
    -device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pcie.0-root-port-6,addr=0x0 \
    -drive file=/home/kvm_autotest_root/images/rhel80-64-virtio-scsi-install-test-.qcow2,aio=threads,if=none,format=qcow2,cache=none,werror=stop,rerror=stop,id=drive-virtio-disk0 \
    -device scsi-hd,bus=virtio_scsi_pci0.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 \
    -drive file=/home/kvm_autotest_root/images/data.raw,aio=threads,if=none,format=raw,cache=none,werror=stop,rerror=stop,id=drive-virtio-disk1 \
    -device scsi-hd,bus=virtio_scsi_pci0.0,drive=drive-virtio-disk1,id=virtio-disk1,bootindex=2 \
    -device pcie-root-port,id=pcie.0-root-port-7,slot=7,chassis=7,addr=0x7,bus=pcie.0 \
    -device virtio-net-pci,mac=9a:63:64:65:66:67,id=idDQ4Oke,vectors=4,netdev=idaNEvdg,bus=pcie.0-root-port-7,addr=0x0  \
    -netdev tap,id=idaNEvdg,vhost=on \
    -m 18432  \
    -smp 12,maxcpus=12,cores=6,threads=1,sockets=2  \
    -cpu 'SandyBridge',+kvm_pv_unhalt \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -monitor stdio \
    -device pcie-root-port,id=pcie.0-root-port-10,slot=10,chassis=10,addr=0x10,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci2,bus=pcie.0-root-port-10,addr=0x0 \
    -drive file=/home/kvm_autotest_root/iso/linux/RHEL-8.0-20190116.1-x86_64-dvd1.iso,aio=threads,if=none,format=raw,cache=none,werror=stop,rerror=stop,id=drive-virtio-disk3,media=cdrom \
    -device scsi-cd,drive=drive-virtio-disk3,bus=virtio_scsi_pci2.0,id=cd_disk1,bootindex=0 \

Comment 19 zhenyzha 2019-01-25 08:51:53 UTC
Hi Kevin,

When I use RHEL8.0 host + RHEL7.6 guest, it can be installed normally.
On the other hand when I use RHEL7.6 host + RHEL7.6 guest, it can be installed normally too.

Hope it helps you.

RHEL8.0 host :
kernel-4.18.0-62.el8.x86_64
qemu-kvm-3.1.0-6.module+el8+2711+98525d2b

RHEL7.6  host :
kernel-3.10.0-957.el7.x86_64
qemu-kvm-rhev-2.12.0-18.el7

Comment 20 Kevin Wolf 2019-01-25 10:01:01 UTC
In other words, RHEL 7.6 guests don't seem to have the problem on the same configuration, it might be a new Anaconda bug.

Can you confirm that 7.6 host + 8.0 guest does show the problem?

Comment 21 zhenyzha 2019-01-25 10:17:54 UTC
(In reply to zhenyzha from comment #19)
> Hi Kevin,
> 
> When I use RHEL8.0 host + RHEL7.6 guest, it can be installed normally.
> On the other hand when I use RHEL7.6 host + RHEL7.6 guest, it can be
> installed normally too.
> 
> Hope it helps you.
> 
> RHEL8.0 host :
> kernel-4.18.0-62.el8.x86_64
> qemu-kvm-3.1.0-6.module+el8+2711+98525d2b
> 
> RHEL7.6  host :
> kernel-3.10.0-957.el7.x86_64
> qemu-kvm-rhev-2.12.0-18.el7

Comment 19 information supplement.
When I use RHEL8.0 host + RHEL7.6 guest the issue of this bug1668248 not appeared.
But found another bug ID:1669446
Description of problem:
When using cdrom to install the system, there are two blockdev disks.choose installation destination,the system automatic multipath configuration disk.
Display one multipath disk:mpatha
But when you use the -drive command,can select these two disk normally.

RHEL8.0 host :
kernel-4.18.0-62.el8.x86_64
qemu-kvm-3.1.0-6.module+el8+2711+98525d2b

Comment 22 Xueqiang Wei 2019-01-25 11:58:51 UTC
(In reply to Kevin Wolf from comment #20)
> In other words, RHEL 7.6 guests don't seem to have the problem on the same
> configuration, it might be a new Anaconda bug.
> 
> Can you confirm that 7.6 host + 8.0 guest does show the problem?



Use the same cmd lines mentioned in Comment 18:

1. install 8.0 guest on RHEL7 with drive, install successfully.
2. install 8.0 guest on RHEL7 with blockdev, hit bug [1].
3. install 7.6 guest on RHEL7 with drive, install successfully.
4. install 7.6 guest on RHEL7 with blockdev, hit bug [2].

5. install 8.0 guest on RHEL8 with drive, install successfully.
2. install 8.0 guest on RHEL8 with blockdev, hit bug [1].
3. install 7.6 guest on RHEL8 with drive, install successfully.
4. install 7.6 guest on RHEL8 with blockdev, hit bug [2]. 

[1] Bug 1668248 - "An unknown error has occurred" when using cdrom to install the system with two blockdev disks.(when choose installation destination)
[2] Bug 1669446 - Automatic multipath configuration when using -blockdev


Versions:
RHEL7:
kernel-3.10.0-991.el7.x86_64
qemu-kvm-rhev-2.12.0-20.el7

RHEL8:
kernel-4.18.0-63.el8.x86_64
qemu-kvm-3.1.0-6.module+el8+2711+98525d2b

Comment 27 Danilo Cesar de Paula 2019-02-08 13:20:28 UTC
Fix included in qemu-kvm-3.1.0-12.module+el8+2778+279c3c9e

Comment 28 Xueqiang Wei 2019-02-12 09:06:03 UTC
According to steps mentioned in Comment 18, tested on qemu-kvm-3.1.0-12.module+el8+2778+279c3c9e with blockdev and drive, the installation are all successful. So set status to VERIFIED.


Versions:

Host:
kernel-4.18.0-67.el8.x86_64
qemu-kvm-3.1.0-12.module+el8+2778+279c3c9e

Guest:
kernel-4.18.0-64.el8.x86_64

Comment 29 zhenyzha 2019-02-13 07:15:26 UTC
In the P9 host according to steps mentioned in Comment 2 and Comment 14, tested on qemu-kvm-3.1.0-14.module+el8+2788+eb400795 with blockdev and drive, the installation are all successful. 


Versions:

Host:
kernel-4.18.0-67.el8.ppc64le
qemu-kvm-3.1.0-14.module+el8+2788+eb400795

Guest:
kernel-4.18.0-67.el8.ppc64le

Comment 31 errata-xmlrpc 2019-05-29 16:05:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1293


Note You need to log in before you can comment on or make changes to this bug.