Bug 1668365 - Please add "xorg-x11-drv-evdev" package to the "Server with GUI" group on RHEL-7 Server
Summary: Please add "xorg-x11-drv-evdev" package to the "Server with GUI" group on RHE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.6
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: 7.7
Assignee: Bohdan Khomutskyi
QA Contact: Jiri Hladky
URL:
Whiteboard:
Depends On:
Blocks: 1647087
TreeView+ depends on / blocked
 
Reported: 2019-01-22 14:34 UTC by Jiri Hladky
Modified: 2019-08-06 11:42 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 11:42:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2351 None None None 2019-08-06 11:42:15 UTC

Description Jiri Hladky 2019-01-22 14:34:46 UTC
Description of problem:

After you install RHEL-7.6 Server followed with the manual installation of X11 with 

yum groupinstall "Server with GUI" 

there is package xorg-x11-drv-evdev missing (not installed). At least on P50 Lenovo Laptop when starting X11 without this package, GDM will not respond as neither keyboard nor mouse are working. 

Please add "xorg-x11-drv-evdev" package to the "Server with GUI" group to resolve this problem. 


Please also note that when installing RHEL-7.6 Workstation, the package "xorg-x11-drv-evdev" is automatically installed. 

Version-Release number of selected component (if applicable):
RHEL-7.6 Server

How reproducible:


Steps to Reproduce:
1. Install RHEL-7.6 Server from Anaconda using the default package selection - it means, without GUI
2. Install "Server with GUI" package group with yum groupinstall "Server with GUI"
3. Check if package xorg-x11-drv-evdev is installed: rpm -qa | grep xorg-x11-drv-evdev


4. (Optional on P50 laptop) Make GUI target the default one with the command:
systemctl set-default graphical.target
5. (Optional on P50 laptop) Start X11 with the command
systemctl isolate graphical.target
and check if mouse & keyboard are working in GDM (without xorg-x11-drv-evdev being installed, on P50 mouse and keyboard will not work) 

Actual results:
xorg-x11-drv-evdev IS NOT installed
Mouse and keyboard are not working in GDM on P50 laptop. The laptop is locked as no input method is working. (Hint - ssh still works)

Expected results:
xorg-x11-drv-evdev IS installed
On P50 laptop, mouse and keyboard are working in GDM

Thanks a lot!
Jirka

Comment 2 Daniel Mach 2019-01-23 18:37:06 UTC
This is a change in comps xml, nothing to be done in yum code.
Reassigning to releng.

Comment 3 Jiri Hladky 2019-01-23 22:41:54 UTC
Thanks for reassigning BZ to the correct group!

You can use 
repoquery --groupmember xorg-x11-drv-evdev 
to check to which groups package belongs.

Currently (tested on RHEL-7.6 Server) package does not belong to any group:

[root@p50 ~]# repoquery --groupmember xorg-x11-drv-evdev 
xorg-x11-drv-evdev-2.10.6-1.el7.x86_64

Thanks!
Jirka

Comment 6 Bohdan Khomutskyi 2019-03-22 15:18:23 UTC
Brian, we need a pm_ack. I'm assigning the bug to you.

Comment 10 Jiri Hladky 2019-04-05 18:03:56 UTC
Tested p50.tpb.lab.eng.brq.redhat.com with RHEL-7.7-20190404.n.0 Server.


$ repoquery --groupmember xorg-x11-drv-evdev 
xorg-x11-drv-evdev-2.10.6-1.el7.x86_64
  @x11

$ rpm -qa | grep xorg-x11-drv-evdev => no match

$ yum groupinstall "Server with GUI" -y

$ rpm -qa | grep xorg-x11-drv-evdev
xorg-x11-drv-evdev-2.10.6-1.el7.x86_64

It's fixed. Thank you!
Jirka

Comment 12 errata-xmlrpc 2019-08-06 11:42:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2351


Note You need to log in before you can comment on or make changes to this bug.