Bug 166837 - OpenOffice.org applications do not switch input language with switch of xkb keyboard layout
OpenOffice.org applications do not switch input language with switch of xkb k...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 07:23 EDT by Victor Ashik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 05:51:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
possible patch (1.42 KB, patch)
2005-08-26 08:52 EDT, Caolan McNamara
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 1035 None None None Never

  None (edit)
Description Victor Ashik 2005-08-26 07:23:01 EDT
Description of problem:

OpenOffice.org applications does not follows xkb at switching of input language.
If I am typing in Russian keyboard layout and OpenOffice is configured to use
Russian by default spell checking is ok, because words are being marked as
Russian. When I switch keyboard layout (using xkb keyboard shortcut) into
English, OpenOffice.org continues to mark words as Russian. I saw more correct
behaviour of OpenOffice build in Ubuntu, which follows current language of xkb
layout.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-24.6.0.EL4
openoffice.org-1.9.117-3.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1.setxkbmap us,ru -option grp:shift_toggle,grp_led:scroll
2.oowriter
3.turn on AutoSpellCheck (underscored ABC button)
4.type in: test ntcn
5.switch into Russin (press two shifts)
6.type in: ntcn (word "test" in Russian)
7.press spacebar
  
Actual results:
Word ntcn is underscored, word test is not. Word test in Russian (typed as nctn)
is underscored too.

Expected results:
Only word nctn is underscored.

Additional info:
The same error is in FC4
Comment 2 Caolan McNamara 2005-08-26 08:52:35 EDT
Created attachment 118150 [details]
possible patch

in theory a patch such as this might do the right thing, more exploration
required
Comment 3 Victor Ashik 2005-08-26 09:48:58 EDT
I just tested Debian 3.1 with their build of OpenOffice - it doesn't have such
feature. So, there should be a patch for Ubuntu.
Comment 4 Victor Ashik 2005-08-26 10:15:58 EDT
I tried to reproduce the behaviour in Ubuntu with no success.
Maybe I made something differently previous time.
I'll try to find it out.
Comment 5 Victor Ashik 2005-08-26 10:31:02 EDT
May be I made a mistake and Ubuntu does not have desired feature.
If it does not - I am sorry for misinformation.

Note You need to log in before you can comment on or make changes to this bug.