Bug 166873 - mod_perl 1.99_16 is unsupported on CPAN - need to upgrade
mod_perl 1.99_16 is unsupported on CPAN - need to upgrade
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mod_perl (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 12:50 EDT by Tony Clayton
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 09:53:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Clayton 2005-08-26 12:50:27 EDT
Description of problem:

Unsupported may be putting it lightly; mod_perl 1.99_16 is dead and buried:
http://www.issociate.de/board/post/198947/%5BRELEASE_CANDIDATE%5D_mod_perl_2.0-RC5.html

There were some last-minute significant API changes in mod_perl 2 which happened
after mod_perl 1.99_16. As a result, some CPAN Apache:: modules will not work
properly with 1.99_16. Mod Perl 2.0.0 has been out since June and is pending a
press release in the near future.

Centos should upgrade to mod_perl 2.0.1 (released June 17) to allow users and
downstream rpm repositories to upgrade to the latest compatible CPAN Apache::
modules.

Version-Release number of selected component (if applicable):
2.0.1

How reproducible:
always

Steps to Reproduce:
1. Check latest mod_perl version in RHEL 4/Centos (yum search mod_perl)
2. Uh-oh, it's 1.99_16 - that's unsupported and dead
Comment 1 Tony Clayton 2005-08-26 13:37:36 EDT
Hmm.. that should be s/Centos/RedHat/.  
Comment 2 Joe Orton 2005-09-12 09:53:43 EDT
Due to the API changes since _16 in the mod_perl 2.00 release, that version will
not be included until the next release of Red Hat Enterprise Linux. Red Hat does
not currently plan to provide a resolution for this in a Red Hat Enterprise
Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects.

Third-party packagers may have a mod_perl 2.00 build available.
Comment 3 David Mansfield 2006-02-16 18:08:52 EST
As a paying customer, I can tell you that having 1.99_16 as your mod_perl is
absolutely PATHETIC.  I'm trying update an OOOLD web server (Redhat 5.2 and
still working, mostly), and the mod_perl in RHEL is some sort of frankenstein
stitched together out of mod_perl 1.0 and mod_perl 2.0 APIs.

The documentation on the net is useless, the code is buggy.  

You could help us out more by just removing it entirely and telling us to go get
the tarball and install it ourselves.

Here's the worst part.  I trusted you.

I did rpm -qa | grep mod_perl, found it was installed and TRUSTED you guys to
have not put a buggy piece of crap into your PRODUCTION operating system.

Strange decision making process.

My entitlements need to be renewed in 30 days, not sure if I should bother.

Just my rant after wasting 4 hours on this.

Note You need to log in before you can comment on or make changes to this bug.