Bug 166881 - Firefox memory leaks
Firefox memory leaks
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 15:05 EDT by Kyrre Ness Sjøbæk
Modified: 2007-12-20 11:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox using a lot of memory (77.25 KB, image/png)
2007-03-04 20:51 EST, William Lovaton
no flags Details
g-s-m after closing firefox (76.26 KB, image/png)
2007-03-04 21:00 EST, William Lovaton
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2005-08-26 15:05:55 EDT
Description of problem:
I you open a big/heavy/etc page in firefox, and then move away from it, it stays
in memory. big pages is also slow to load (seems exponentially - the "load
percentage" bar in lower rigth corner goes slower and slower and slower...)

Version-Release number of selected component (if applicable):
firefox-1.1-0.2.7.deerpark.alpha2.1

How reproducible:
Every time

Steps to Reproduce:
1.Enter a huge page. Example:
http://folk.uio.no/~kyrrens/primes.txt
(its a 6 MB pure-ascii file)
2.Wait untill its loaded (and be happy you didn't show firefox the 1GB version
with much more numbers :P ). Notice memory consumption rising in the
gnome-system-monitor panel-applet
3.Visit another page. I tried slashdot.
4.Notice that memory usage doesn't drop.
5.Close firefox. Computer churns, a bit. Suddenly you have a lot of free memory.
  
Actual results:
Memory leak

Expected results:
Not cache *everything*? I dont think it even drops when you close the tab it is
kept in...

Additional info:
Comment 1 Warren Togami 2005-10-01 00:28:23 EDT
Any better with latest rawhide?
Comment 2 Kyrre Ness Sjøbæk 2005-10-22 08:59:37 EDT
I'm not shure. It does *not* release any RAM when i open another tab with a
ligther site (such as slashdot :P), and then close the mega-tab, and it does
release a lot of ram when firefox is closed. But this is 128 MB system, so "a
lot of ram" is... relative.

Just switch on gnome-system-monitor panel applet, activate memory and swap
display, and try yourself.

When that is said, i think i remember it used even *more* RAM before than now -
the increase in ram usage when i load up the page is really barely visible (the
time consumption is not - and judging by the network and cpu activity, rendering
is what takes time, not downloading (this is a 600 mhz pentium 3 mobility)
Comment 3 William Lovaton 2007-03-04 20:43:34 EST
I'm seeing this problem too.

I am using Fedora 7 Test 2 with the latest updates and firefox 2.0.0.2-1.fc7.  I
can reproduce it when visiting web pages with lots of images, it seems to be
using the X server memory to store images but it doesn't free them when I close
the tab or go to any other site, it just keeps them in memory forever.

I'll attach 2 gnome-system-monitor screen shots to show the problem.  My system
is an Athlon 2000 XP with 512 megs of RAM and 512 megs of swap,  I would say
this is more than enough to run a few programs but with firefox things get very
tight.

This is a very old problem with firefox IMHO.
Comment 4 William Lovaton 2007-03-04 20:51:26 EST
Created attachment 149231 [details]
firefox using a lot of memory

This shows how much memory firefox use when browsing site with lots of pictures
(not all that much really).  Specially the X server memory, just look the two
first items of the list.
Comment 5 William Lovaton 2007-03-04 21:00:34 EST
Created attachment 149232 [details]
g-s-m after closing firefox

This one shows the X server memory after closing firefox, there were a lot of
RAM and swap freed.  During this I got to 99% of RAM and 99% of swap... and
remember, I have 512 of RAM and 512 of swap.  Obviously I was running pirut and
gnome-terminal but that shouldn't put my system near to an OOM situation.
Comment 6 Matěj Cepl 2007-12-20 11:47:10 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.