Bug 1668825 - serviceaccounttoken/service-ca.crt is missing
Summary: serviceaccounttoken/service-ca.crt is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: All
OS: All
high
high
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
: 1659331 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-23 16:24 UTC by David Eads
Modified: 2019-06-04 10:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:23 UTC

Description David Eads 2019-01-23 16:24:08 UTC
Workloads in 3.x relied upon the service-ca.crt being present to validate serving certificates. That file isn't present in 4.0 clusters and the new mechanism of configmap injection cannot be used on 3.x.  In order to run 3.x workloads on the 4.0 cluster, the serviceaccounttoken/service-ca.crt needs to be present.

Comment 1 Eric Paris 2019-01-23 16:25:27 UTC
I believe this must be fixed to ship 4.0

Comment 4 Chuan Yu 2019-03-14 03:55:48 UTC
Verified.

$ oc get secret -n default default-token-7gwqs -o json | jq '.data'
....
 "service-ca.crt": "LS0tLS1CRUdJTiBD.......
....

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-03-13-233958   True        False         35m     Cluster version is 4.0.0-0.nightly-2019-03-13-233958

Comment 5 Matt Rogers 2019-03-28 20:34:02 UTC
*** Bug 1659331 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2019-06-04 10:42:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.