Bug 1668900 - Brick grafana based dashboards can't be directly reached from "Brick Details" page of RHGSWA web
Summary: Brick grafana based dashboards can't be directly reached from "Brick Details"...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: RHGS 3.4.z Batch Update 4
Assignee: Neha Gupta
QA Contact: Elena Bondarenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-23 20:35 UTC by Martin Bukatovic
Modified: 2019-03-27 03:51 UTC (History)
7 users (show)

Fixed In Version: tendrl-ui-1.6.3-15.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-27 03:49:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0660 None None None 2019-03-27 03:51:10 UTC
Github Tendrl ui issues 1093 None None None 2019-01-24 11:50:33 UTC

Description Martin Bukatovic 2019-01-23 20:35:48 UTC
Description of problem
======================

Brick grafana based dashboards can't be directly reached from "Brick Details"
page of RHGSWA web.

This is caused by change of brick ids in grafana based dashboard as described
in BZ 1660779. To fix this, we need to update links in the brick details page
accordingly.

Version-Release number of selected component
============================================

tendrl-ui-1.6.3-14.el7rhgs.noarch (as of BU3)

How reproducible
================

100 %

Steps to Reproduce
==================

1. Create gluster trusted storage pool, with at least one volume
2. Install RHGSWA via tendrl-ansible
3. Import cluster into RHGSWA
4. Go to Brick Details page of some host (Hosts -> some host -> Bricks)
5. Click on Dashboard button for any brick shown there

Actual results
==============

Grafana based dashboard is shown in new tab, but the charts contains
no values. Then after few seconds, the page reloads to the first brick
on the machine, no matter which brick was originally supposed to be shown.

Expected results
================

The link goes to the right dashboard, correct values are shown directly
without any redirection.

Comment 1 gowtham 2019-01-24 11:50:33 UTC
PR is under review: https://github.com/Tendrl/ui/pull/1094

Comment 2 Martin Bukatovic 2019-01-24 19:09:48 UTC
Note for testing: this applies to "Brick Details" as shown in Volume detail page as well.

Comment 5 Elena Bondarenko 2019-02-13 16:55:31 UTC
Brick details can be directly reached from Brick Details page of both hosts and volumes.

Comment 8 errata-xmlrpc 2019-03-27 03:49:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0660


Note You need to log in before you can comment on or make changes to this bug.