Bug 1668910 - EPEL7 - nodejs-node-stringprep won't install on RHEL 7.6
Summary: EPEL7 - nodejs-node-stringprep won't install on RHEL 7.6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nodejs-node-stringprep
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: EPEL7FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-01-23 21:12 UTC by Troy Dawson
Modified: 2020-11-05 09:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-18 15:16:55 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Troy Dawson 2019-01-23 21:12:48 UTC
Current nodejs-node-stringprep for EPEL7 (nodejs-node-stringprep-0.2.3-5.el7) requires
  nodejs = 0.10
The nodejs in EPEL7 is currently nodejs-6.14.3

Please fix this package so that it can be installed in RHEL 7.6.
If you have not responded in a week, we will have a proven packager fix it.
If you know you will not be able to get to it and would like it fixed sooner, please let us know in this bug.
If you feel this package should no longer be in EPEL7, please let us know in this bug.

Comment 1 Tom Hughes 2019-01-23 21:17:18 UTC
When you make threats to have a proven packager do it that kind of implies that you know what the problem is, so maybe you would care to enlighten us?

Comment 2 Troy Dawson 2019-01-23 21:26:16 UTC
This is part of an effort to clean up the EPEL7 repository.
We have a proven packager that has volunteered to work on any packages that the maintainers feel they need help with.
Most packages that fall into this category just need a rebuild, sometimes with %nodejs_fixdep line or two added to the spec file.
But this particular package we noticed doesn't just rebuild.  gyp is failling because it doesn't see the nan module, even though the nan module is installed.
When we got to that point, we figured we'd stop and open the bugzilla incase the regular maintainer already knew what the problem was.
 ...
um ... I guess I should stop using the generic 'we' and say I, since I'm the proven packager.  If you want some help with this, I'll gladly help.

Comment 3 Tom Hughes 2019-01-23 21:30:19 UTC
It's not actually my package but I usually look after rebuilds for the binary modules on Fedora when Node.js bumps.

I just tried a build with changes up to Node 6.x merged from Fedora but it fails due to a dependency on proxyquire which isn't in epel7 yet so we'll probably need to get that in.

Comment 4 Troy Dawson 2019-01-23 21:58:02 UTC
Before we go adding packages, we need to make sure anyone still wants this package.
Nothing depends on it, it hasn't been installable for almost 2 years, and not a single bugzilla is open for it.
I'm not saying I'm going to remove it right away, not even after a couple of weeks.  But with the last wave of EPEL7 packages I did this for, many of the package maintainers wanted their packages removed, and it was easier for me to do it in this batch of packages than for them to do it.

Comment 5 Tom Hughes 2019-01-23 22:26:03 UTC
Oh in that case lets forget it. I don't normally bother about EPEL stuff to be honest.

Comment 6 Troy Dawson 2019-02-01 14:58:36 UTC
If I do not hear anything in a week, I will remove nodejs-node-stringprep from EPEL7.

Comment 7 Troy Dawson 2019-02-15 17:15:08 UTC
I have retired nodejs-node-stringprep from EPEL7.
I will close the ticket when I have verified it is not in the EPEL7 anymore.

Comment 8 Troy Dawson 2019-02-18 15:16:55 UTC
Verified
Package is no longer in EPEL7


Note You need to log in before you can comment on or make changes to this bug.