Bug 1669055 - fc29 net install stuck on grub prompt after net install on ppc64le
Summary: fc29 net install stuck on grub prompt after net install on ppc64le
Status: CLOSED DUPLICATE of bug 1669256
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 29
Hardware: powerpc
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2019-01-24 08:29 UTC by Michel Normand
Modified: 2019-01-28 10:31 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-01-28 10:31:15 UTC


Attachments (Terms of Use)
anaconda.log (46.85 KB, text/plain)
2019-01-24 09:29 UTC, Michel Normand
no flags Details
journal.log (1.38 MB, text/plain)
2019-01-24 09:30 UTC, Michel Normand
no flags Details
GRUB menu after netinstalling F29 via kickstart (59.58 KB, image/jpeg)
2019-01-24 18:24 UTC, Michel Alexandre Salim
no flags Details

Description Michel Normand 2019-01-24 08:29:28 UTC
fc29 net install stuck on grub prompt after net install on ppc64le

Try a net install on a ppc64le guest;
the install seems to properly work in anaconda until completion, but after reboot the console is stuck at grub prompt.
 If I try a grub exit, a short error msg is displayed and switch back to grub.

=== grub menu:
      Reboot                                                                    
      Exit to Open Firmware <= selected that one                                                                                                                             
                                                            
      Use the ^ and v keys to change the selection.                       
      Press 'e' to edit the selected item, or 'c' for a command prompt.   
      Press Escape to return to the previous menu. 
===
W3411: Client application returned.

E3406: Client application returned an error.

Trying to load:  from: /vdevice/v-scsi@2000/disk@8000000000000000 ...   Successfully loaded

      Minimal BASH-like line editing is supported. For the first word,
      TAB lists possible command completions. Anywhere else TAB lists
      possible device or file completions.


grub> 
grub> exit
grub> 
W3411: Client application returned.

E3406: Client application returned an error.

Trying to load:  from: /vdevice/v-scsi@2000/disk@8000000000000000 ...   Successfully loaded

      Minimal BASH-like line editing is supported. For the first word,    
      TAB lists possible command completions. Anywhere else TAB lists     
      possible device or file completions.                                


grub> 
===

There was no such failure at GA time, so I assume problem related to last updates of fc29; do not know how to identify which one.

Comment 1 Michel Normand 2019-01-24 09:28:37 UTC
* using "Rescue a Fedora System" was able to mount installed disk
  and retrieve from /var/log the anaconda logs
* in anaconda.log there was a reported ERR about "failed to recreate path"
* in journal.log same failed action but program still return code: 0
  So not sure this is the cause of failure at reboot time.
* I will attach the two logs.

=== extract anaconda.log
08:11:55,786 INF installation: Task started: Install bootloader (17/18)
08:11:55,788 INF bootloader: boot loader stage1 target device is sda1
08:11:55,788 INF bootloader: boot loader stage2 target device is sda2
08:11:55,864 DBG bootloader: new default image: <pyanaconda.bootloader.LinuxBootLoaderImage object at 0x7fff81c78e10>
08:11:55,866 ERR bootloader: failed to recreate path to default kernel image
08:11:56,148 DBG bootloader: updateNVRAMBootList: self.stage1_device.path = /dev/sda1
=== extract journal.log
Jan 24 08:11:55 localhost anaconda[3679]: anaconda: installation: Task started: Install bootloader (17/18)
Jan 24 08:11:55 localhost anaconda[3679]: anaconda: bootloader: boot loader stage1 target device is sda1
Jan 24 08:11:55 localhost anaconda[3679]: anaconda: bootloader: boot loader stage2 target device is sda2
Jan 24 08:11:55 localhost anaconda[3679]: anaconda: bootloader: new default image: <pyanaconda.bootloader.LinuxBootLoaderImage object at 0x7fff81c78e10>
Jan 24 08:11:55 localhost anaconda[3679]: anaconda: bootloader: failed to recreate path to default kernel image
Jan 24 08:11:56 localhost anaconda[3679]: anaconda: bootloader: updateNVRAMBootList: self.stage1_device.path = /dev/sda1
Jan 24 08:11:56 localhost anaconda[3679]: program: Running... nvram --print-config=boot-device
Jan 24 08:11:56 localhost audit[3667]: AVC avc:  denied  { read } for  pid=3667 comm=746D75783A20736572766572 path="/dev/ptmx" dev="devtmpfs" ino=1106 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:ptmx_t:s0 tclass=chr_file permissive=1
Jan 24 08:11:56 localhost audit[3667]: SYSCALL arch=c0000015 syscall=145 success=yes exit=71 a0=b a1=7fffd67f14f8 a2=1 a3=3d0 items=0 ppid=1 pid=3667 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=746D75783A20736572766572 exe="/usr/bin/tmux" subj=system_u:system_r:init_t:s0 key=(null)
Jan 24 08:11:56 localhost audit: PROCTITLE proctitle=2F7573722F62696E2F746D7578002D75002D66002F7573722F73686172652F616E61636F6E64612F746D75782E636F6E66007374617274
Jan 24 08:11:56 localhost anaconda[3679]: program: 
Jan 24 08:11:56 localhost anaconda[3679]: program: Return code: 0
===

Comment 2 Michel Normand 2019-01-24 09:29 UTC
Created attachment 1523042 [details]
anaconda.log

Comment 3 Michel Normand 2019-01-24 09:30 UTC
Created attachment 1523043 [details]
journal.log

Comment 4 Michel Normand 2019-01-24 10:28:27 UTC
There is no such problem, if trying a net install of fc28.

Comment 6 caleb 2019-01-24 12:46:10 UTC
Having the same problem installing fedora 29 through the net installer on a thinkpad T480. The text based installer appears to be broken on all systems.

Comment 7 Dan Horák 2019-01-24 15:57:49 UTC
There doesn't seem to be any update to grub2 after the F-29 GA, but there was an update to anaconda. But the change seems completely unrelated.

Comment 8 Michel Alexandre Salim 2019-01-24 18:24 UTC
Created attachment 1523276 [details]
GRUB menu after netinstalling F29 via kickstart

Seeing the same kickstarting F29 on both Thinkpads and VirtualBox VMs

Comment 9 Michel Normand 2019-01-25 14:06:25 UTC
may be same as other bug https://bugzilla.redhat.com/show_bug.cgi?id=1669256#c0 that already pushed a correction in f29 https://bodhi.fedoraproject.org/updates/FEDORA-2019-827d700f48

Comment 10 Michel Normand 2019-01-28 10:31:15 UTC
problem solved with last update pushed as correction of other bug#1669256

*** This bug has been marked as a duplicate of bug 1669256 ***


Note You need to log in before you can comment on or make changes to this bug.