Bug 166910 - lm_sensors-debuginfo doesn't contain any debuginfo
Summary: lm_sensors-debuginfo doesn't contain any debuginfo
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lm_sensors   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-27 06:52 UTC by Hans de Goede
Modified: 2015-03-05 01:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-01 17:37:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2005-08-27 06:52:30 UTC
I've been busy writing a driver for a sensors chip on my new motherboard, the
driver worked ok, but I had trouble accessing it through libsensors based
programs, so I wanted to debug libsensors. However even after installing
lm_sensors-debuginfo, debugging was still inpossible.

The problem is that the current spec- (and make-) file don't pass -g to gcc when
building. Actually the current specfile doesn't pass any of the Fedora specific
CFLAGS to make, thus causing lm_sensors to be build without debuginfo,
fortifysource and stacksmashing protection.

I fixed this by adding:
export CFLAGS="%{optflags}"

Directly under %build, or you could add CFLAGS="%{optflags}" to the make command
under %build.

Comment 1 Phil Knirsch 2005-09-01 17:37:27 UTC
Fixed in latest development version.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.