Bug 1669119 - perl-TeX-Encode-2.004-4.fc30 FTBFS: t/Encode-LaTeX.t test fails: Unknown check argument: expected one of undef, FB_DEFAULT, FB_CROAK, FB_QUIET or FB_WARN
Summary: perl-TeX-Encode-2.004-4.fc30 FTBFS: t/Encode-LaTeX.t test fails: Unknown chec...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-TeX-Encode
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
: 1675640 (view as bug list)
Depends On:
Blocks: F30FTBFS
TreeView+ depends on / blocked
 
Reported: 2019-01-24 11:33 UTC by Petr Pisar
Modified: 2019-02-12 12:36 UTC (History)
3 users (show)

Fixed In Version: perl-TeX-Encode-2.005-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 12:36:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github athreef TeX-Encode issues 4 None None None 2019-01-24 11:33:05 UTC

Description Petr Pisar 2019-01-24 11:33:06 UTC
perl-TeX-Encode-2.004-4.fc30 fails to build in F30 because a test fails:

t/02check.t ............ ok
BUILDSTDERR: Unknown check argument: expected one of undef, FB_DEFAULT, FB_CROAK, FB_QUIET or FB_WARN at /builddir/build/BUILD/TeX-Encode-2.004/blib/lib/TeX/Encode.pm line 52.
BUILDSTDERR: 	TeX::Encode::encode(TeX::Encode=HASH(0x1002012e070), "eacute = '\x{e9}'", "") called at t/Encode-LaTeX.t line 19
BUILDSTDERR: # Looks like your test exited with 255 just after 1.
t/Encode-LaTeX.t ....... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 36/37 subtests 

This is triggered by upgrading perl-Encode from 4:2.98 to 4:2.99.

Comment 1 Petr Pisar 2019-02-12 12:18:40 UTC
*** Bug 1675640 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.