Bug 166923 - hwclock will not run on a non audit-enabled kernel
hwclock will not run on a non audit-enabled kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-27 18:14 EDT by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-01 10:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-08-27 18:14:58 EDT
hwclock will not run on latest -mm kernels that do not have audit support
compiled in - it fails with a message of "Error - unable to connect to audit
system".  This breaks all hardware clock setting functionality in the
initscripts and from the command line in non-audit enabled kernels.  While all
official Fedora kernels do have audit support, custom built user kernels may not
necessarily have this because audit support is not generally required.

A similar problem came up with similar code in pam-0.80-6, and pam was modified
to not use audit if it detected that audit was not enabled in the kernel. 
util-linux should do the same.  See bugzilla #166422 for more information.
Comment 4 Fedora Update System 2005-09-06 21:07:07 EDT
From User-Agent: XML-RPC

util-linux-2.12p-9.9 setup-2.5.44-1.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Reuben Farrelly 2005-09-09 05:23:43 EDT
Yes, confirmed as fixed in rawhide.  Thanks..

Note You need to log in before you can comment on or make changes to this bug.