Bug 1669286 - [v2v][OSP][RHV]Migration with VDDK transformation method fails when used a VM with International Characters or with VM with space in name
Summary: [v2v][OSP][RHV]Migration with VDDK transformation method fails when used a VM...
Keywords:
Status: CLOSED DUPLICATE of bug 1669240
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.10.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Brett Thurber
QA Contact: Shveta
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks: 1668816
TreeView+ depends on / blocked
 
Reported: 2019-01-24 20:52 UTC by Shveta
Modified: 2019-02-26 20:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-26 20:49:19 UTC
Category: Bug
Cloudforms Team: V2V
Target Upstream Version:


Attachments (Terms of Use)
Logs of vm with space in name (1.59 MB, application/octet-stream)
2019-01-24 20:52 UTC, Shveta
no flags Details
Vm name with international characters (78.82 KB, image/png)
2019-01-24 20:54 UTC, Shveta
no flags Details
Vm name with space (74.42 KB, image/png)
2019-01-24 20:55 UTC, Shveta
no flags Details

Description Shveta 2019-01-24 20:52:42 UTC
Created attachment 1523322 [details]
Logs of vm with space in name

Description of problem:
This is a regression BZ . Copy of https://bugzilla.redhat.com/show_bug.cgi?id=1581739

Version-Release number of selected component (if applicable):
5.10.0.32.20190115185124_c957ada

How reproducible:


Steps to Reproduce:
1. Add source(Vmware) and target provider(RHV/OSP)
2. Create a VMware VM named something like:  �Ää or a VM containing space in the name (Ex: rhel 7)
3. Migrate with v2v using ManageIQ v2v UI.
3. Migration completes , VM is created on RHV/OSP
4. But migration plan shows error .

Actual results:
Plan finishes with error . 
Also the downloaded log file with international characters name does not open 
and shows invalid encoding .

Expected results:


Additional info:
Logs are attached

Comment 3 Shveta 2019-01-24 20:54:15 UTC
Created attachment 1523323 [details]
Vm name with international characters

Comment 4 Shveta 2019-01-24 20:55:13 UTC
Created attachment 1523324 [details]
Vm name with space

Comment 6 Shveta 2019-02-25 19:05:23 UTC
This BZ is very similar to https://bugzilla.redhat.com/show_bug.cgi?id=1678385 and might have been fixed .
I will check with OSP tomorrow( some infra issues today ) and close this incase it got fixed there .

Thanks, 
Shveta

Comment 7 Shveta 2019-02-26 02:29:37 UTC
Tested again .
Vm with space in name works for OSP but not in RHV .
Vm with international chars work in RHV but not in OSP.

Upstream BZ : https://github.com/ManageIQ/manageiq/issues/18485

Comment 8 Fabien Dupont 2019-02-26 10:09:49 UTC
I'm not sure I understand how this BZ is a regression of https://bugzilla.redhat.com/show_bug.cgi?id=1581739. International characters still work in RHV, which was the object of this BZ.

Now, you have an issue with international characters in OSP and spaces in RHV. Issues with OSP are not regressions as we didn't support OSP prior to IMS 1.1 / CFME 5.10. Issue with space in VM name for RHV is new and neither a regression as it was not tested before, if I understand correctly.

Also, the fix international characters for OSP and space for RHV is tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1669240. So, I'm tempted to mark this BZ as duplicate.

Comment 9 Shveta 2019-02-26 16:29:37 UTC
Hi Fabien , 

I agree this might not be a regression. Removing regression keyword .
I think the reason why I opened this bug separately is because of VDDK mode .
That BZ is for SSH mode.
I am okay to mark this as duplicate if both can be fixed and tracked in that BZ .

Comment 10 Fabien Dupont 2019-02-26 16:51:57 UTC
Yes, for me we should track all in the same BZ.
International characters with OSP is a known issue on OSP side: https://bugzilla.redhat.com/show_bug.cgi?id=1661913.
So, it seems we track an issue space in VM name when migrating to RHV. And, if my intuition is correct, this impacts both SSH and VDDK as it fails after disks conversion.

Comment 11 Shveta 2019-02-26 17:56:28 UTC
Ok please close this bug.
I have commented on the other BZ to track both SSH and VDDK .

Comment 12 Fabien Dupont 2019-02-26 20:49:19 UTC

*** This bug has been marked as a duplicate of bug 1669240 ***


Note You need to log in before you can comment on or make changes to this bug.