Bug 1669290 - Wildcard DNS zones are not deleted along with a ClusterIngress
Summary: Wildcard DNS zones are not deleted along with a ClusterIngress
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-24 21:05 UTC by Dan Mace
Modified: 2019-06-04 10:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:22 UTC

Description Dan Mace 2019-01-24 21:05:49 UTC
Description of problem:

Deleting a ClusterIngress using the Cloud highAvailability type (e.g. the default router) orphans any corresponding wildcard DNS records in the cluster's public and private zones.

Version-Release number of selected component (if applicable):

quay.io/openshift-release-dev/ocp-release:4.0.0-0.1

How reproducible:

Create a new cluster and `oc delete -n openshift-ingress-operator clusteringresses/default`

Actual results:

Wildcard DNS records for the ingress domain still exist in the Route53 public and private zones for the cluster.

Expected results:

The wildcard DNS records should be deleted when the clusteringress is deleted.

Additional info:

Comment 2 Hongan Li 2019-02-21 03:26:16 UTC
verified with 4.0.0-0.nightly-2019-02-20-194410 and the issue has been fixed.

Comment 5 errata-xmlrpc 2019-06-04 10:42:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.