Bug 1669300 - [marketplace] Operators Hub UI displays the same provider for operators from the same OperatorSource
Summary: [marketplace] Operators Hub UI displays the same provider for operators from ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: lgallett
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-24 21:18 UTC by Sami Shahin
Modified: 2019-06-04 10:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Three operators from the "certified-operators" OperatorSource with the same provider in the Operator Hub UI. (241.83 KB, image/png)
2019-01-24 21:18 UTC, Sami Shahin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:22 UTC

Description Sami Shahin 2019-01-24 21:18:06 UTC
Created attachment 1523337 [details]
Three operators from the "certified-operators" OperatorSource with the same provider in the Operator Hub UI.

Description of problem:
All operators displayed in Operator Hub UI from the same OperatorSource will be displayed with the same provider in their tile and modal. The provider doesn't match the provider listed in the packagemanifest for these operators (except for the operator whose provider is being duplicated).

Version-Release number of selected component (if applicable):
1) clusterversion:4.0.0-0.alpha-2019-01-22-055501
2) marketplace image:
3) olm image:
4) console image

How reproducible:
always

Steps to Reproduce:
1. Click "Operator Hub" under the "Catalog" header in the side menu of the console.
2. Select the "Certified" "Provider Type" in the filter bar.

Actual results:
1. View that couchbase-enterprise, dynatrace-monitoring, and mongodb-enterprise have the text "provided by MongoDB, Inc" below their titles.
2. Clicking on any of these three operators will show their Modal also lists the provider as "MongoDB, Inc".

Expected results:
1. See the correct provider for these three operators: "Couchbase", "Dynatrace LLC", and "MongoDB, Inc", respectively.

Additional info:

Comment 1 Sami Shahin 2019-01-24 21:31:31 UTC
** Accidentally left out the other images involved, here they are:

2) marketplace image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ba28700ae1e0cd8bf2caf1930de777d495c5bddd0ca9356ad1832d9b90f8cb84
3) olm image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ad3dbbeac14175ace16b2bd51700e31ad16c1419b123b9698b8c4e069542f9e3
4) console image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ff9b8324d684385b57556a3067de45e5c429a54749a31d6359ca6a7e09e1c124

Comment 2 Evan Cordell 2019-02-25 16:30:05 UTC
This has been fixed in the latest release

Comment 4 Jian Zhang 2019-02-27 05:47:59 UTC
Still encounter this issue on the Web console for the latest build: 4.0.0-0.nightly-2019-02-26-125216
The value of the provider is Coubase, but the provide value of label still is "MongoDB, Inc".
[jzhang@dhcp-140-18 ~]$ oc get packagemanifest couchbase-enterprise -o yaml -n openshift-marketplace
apiVersion: packages.apps.redhat.com/v1alpha1
kind: PackageManifest
metadata:
  creationTimestamp: 2019-02-27T05:33:15Z
  labels:
    catalog: certified-operators
    catalog-namespace: openshift-marketplace
    olm-visibility: hidden
    openshift-marketplace: "true"
    opsrc-datastore: "true"
    opsrc-provider: certified
    provider: MongoDB, Inc
    provider-url: ""
...
  defaultChannel: preview
  packageName: couchbase-enterprise
  provider:
    name: Couchbase

[jzhang@dhcp-140-18 ~]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-02-26-125216   True        False         105m    Cluster version is 4.0.0-0.nightly-2019-02-26-125216

OLM image info:
               io.openshift.build.commit.id=1ac9ace63034ea90f31e5ad33435d3f5476c7d85
               io.openshift.build.commit.url=https://github.com/operator-framework/operator-lifecycle-manager/commit/1ac9ace63034ea90f31e5ad33435d3f5476c7d85
               io.openshift.build.source-location=https://github.com/operator-framework/operator-lifecycle-manager

Console image info:
             io.openshift.build.commit.id=a0b75bcc5799c700b44e753b222dab73e56a36b2
             io.openshift.build.commit.url=https://github.com/openshift/console/commit/a0b75bcc5799c700b44e753b222dab73e56a36b2
             io.openshift.build.source-location=https://github.com/openshift/console

Comment 5 lgallett 2019-02-27 15:33:07 UTC
PR with the fix https://github.com/openshift/console/pull/1235

Comment 6 Jian Zhang 2019-03-01 01:51:34 UTC
@Evan,

One question, I saw the fix PR just changed the value of the "provider" to "status.provider.name" from the "metadata.labels.provider".
But, the "metadata.labels.provider" of the couchbase-enterprise still is "MongoDB, Inc". It's incorrect, we should fix it too. Correct me if I'm wrong.

Comment 7 aravindh 2019-03-01 03:15:34 UTC
Redirecting the question to Lance who authored the PR

Comment 8 lgallett 2019-03-01 14:08:22 UTC
@Jian Zhang

From this comment https://github.com/openshift/console/pull/1235#issuecomment-467938141 by Alec Merdler, it looks like the issue with labels.provider may come from the couchbase-enterprise CSV. If this is not the case, I would raise a different bug on the OLM side because they own the packagemanifest resource and will be better equipped to resolve this.

Thanks!

Comment 9 lgallett 2019-03-05 17:50:19 UTC
PR is still trying to merge. For some reason the e2e test is not passing. Will update here when it's merged.

Comment 11 Fan Jia 2019-03-19 05:49:32 UTC
testenv:
cv: 4.0.0-0.nightly-2019-03-18-200009
marketplace image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:c802c1681883549a6a6b123719866b382218294259d55d5464415cf9464b189f
marketplace commit:68b01f6507267f6deefa952a1034b74a5e8480bf

The UI can display the operator provider as the config in the packagemanifest.

Comment 12 Jian Zhang 2019-03-19 06:32:16 UTC
LGTM, verify it.

> If this is not the case, I would raise a different bug on the OLM side because they own the packagemanifest resource and will be better equipped to resolve this.
I created bug 1690241 for this "labels.provider" issue.
[jzhang@dhcp-140-18 ocp18]$ oc get packagemanifest couchbase-enterprise -o yaml -n openshift-marketplace|grep provider -A 2
    opsrc-provider: certified
    provider: MongoDB, Inc
    provider-url: ""
  name: couchbase-enterprise
  namespace: openshift-marketplace
--
      provider:
        name: Couchbase
      version: 1.1.0
--
  provider:
    name: Couchbase

Comment 14 errata-xmlrpc 2019-06-04 10:42:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.