Bug 1669303 - [marketplace] Operator Hub is always loaded partially scrolled down
Summary: [marketplace] Operator Hub is always loaded partially scrolled down
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.1.0
Assignee: Jeff Phillips
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-24 21:42 UTC by Sami Shahin
Modified: 2019-06-04 10:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Too many categories of operators caused the filter input to be scrolled off screen Consequence: When auto-focusing on the filter input the window would scroll down to make the input field visible, hence, starting the window scrolled down. Fix: Set auto-focus to not scroll. Reduce the number of categories Result: Typically there are not enough categories to cause the input to be off screen so no scroll is necessary. If there is, most browsers will not scroll but Firefox will still scroll.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
View of page when loaded. (306.28 KB, image/png)
2019-01-24 21:42 UTC, Sami Shahin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:22 UTC

Description Sami Shahin 2019-01-24 21:42:07 UTC
Created attachment 1523340 [details]
View of page when loaded.

Description of problem:
When Operator Hub loads I start at the middle of the page rather than the top of the page. I can't see the "Operator Hub" title or the description without scrolling up. I do see all the tiles.

Version-Release number of selected component (if applicable):
1) clusterversion:4.0.0-0.alpha-2019-01-22-055501
2) marketplace image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ba28700ae1e0cd8bf2caf1930de777d495c5bddd0ca9356ad1832d9b90f8cb84
3) olm image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ad3dbbeac14175ace16b2bd51700e31ad16c1419b123b9698b8c4e069542f9e3
4) console image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ff9b8324d684385b57556a3067de45e5c429a54749a31d6359ca6a7e09e1c124

How reproducible:
Always

Steps to Reproduce:
1. Open up Operator Hub

Actual results:
1. Page loads scrolled down, the top of the screen is just above the first row of operators.

Expected results:
1. Clicking on Operator Hub loads the page scrolled all the way to the top, with the Operator Hub title visible without scrolling.

Additional info:

Comment 1 Jeff Phillips 2019-01-29 21:11:59 UTC
The issue is the initial focus being on the `Filter by Keyword` text input. Due to the high number of categories, the view is scrolling to that the input is in view.

Comment 2 aravindh 2019-01-29 21:45:26 UTC
So is this not a bug?

Comment 3 Jeff Phillips 2019-01-29 22:33:37 UTC
No, it is a bug. We need to determine if we can fix it by preventing scroll (maybe not have initial focus on the filter input) or by removing the setting of initial focus on the input.

Comment 4 Jeff Phillips 2019-01-30 13:13:25 UTC
PR: https://github.com/openshift/console/pull/1150

Comment 5 Jeff Phillips 2019-01-30 13:17:28 UTC
(Please ignore previous PR, it was a mistake)

PR: https://github.com/openshift/console/pull/1151

Comment 6 Fan Jia 2019-02-14 06:04:36 UTC
The operator hub basic Page loads still scrolled down(still have initial focus on the filter input, can't see the Operator Hub title)

env:
clusterversion: 4.0.0-0.nightly-2019-02-13-204401
console : quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:65d45bc11133e47d739c729969241654813830bb315ad805e71e7a677a8e73e6
console commit : https://github.com/openshift/console/commit/e05b0365a496188c5cd35fc9efa51a153bb2ae95  
marketplace : quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:da0e454dfd9f4d9b142dedc23175a19133b47b0f47857f6b4403c04681dbc6a3
olm: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:6a6d55c7119f4ba1815c41d5e3cf5931c4787409030c203dfa2a7ab2db829f74

Comment 7 Fan Jia 2019-03-05 08:34:51 UTC
Operator Hub loads I start at the top of the page
test env:
clusterversion:4.0.0-0.nightly-2019-03-04-234414
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:af4309742b18e8e0e4dc2c7f96c044ede1f2d40c325a9462a25398c39c67bd9f

Comment 10 errata-xmlrpc 2019-06-04 10:42:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.