Bug 1669304 - [marketplace] Operator Hub "Create Operator Subscription" page stretches operator icons to fit a square
Summary: [marketplace] Operator Hub "Create Operator Subscription" page stretches oper...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Jeff Phillips
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-01-24 21:47 UTC by Sami Shahin
Modified: 2019-06-04 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The image area was set to be 40x40 Consequence: Image would be drawn to fixed size square causing the image to stretch Fix: Set only the image area's width property Result: The image's original aspect ratio will remain
Clone Of:
Environment:
Last Closed: 2019-06-04 10:42:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
An operator with a long rectangular icon that is squished to fit a square in the Create Operator Subscription page. (225.15 KB, image/png)
2019-01-24 21:47 UTC, Sami Shahin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:42:22 UTC

Description Sami Shahin 2019-01-24 21:47:37 UTC
Created attachment 1523342 [details]
An operator with a long rectangular icon that is squished to fit a square in the Create Operator Subscription page.

Description of problem:
Operator Hub's subscribe page stretches operator icons into squares.

Version-Release number of selected component (if applicable):
1) clusterversion:4.0.0-0.alpha-2019-01-22-055501
2) marketplace image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ba28700ae1e0cd8bf2caf1930de777d495c5bddd0ca9356ad1832d9b90f8cb84
3) olm image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ad3dbbeac14175ace16b2bd51700e31ad16c1419b123b9698b8c4e069542f9e3
4) console image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-22-055501@sha256:ff9b8324d684385b57556a3067de45e5c429a54749a31d6359ca6a7e09e1c124

How reproducible:
Requires an operator with a non-square icon.

Steps to Reproduce:
1. Open up Operator Hub
2. Select an operator with a non-square icon, and click "install" on the modal.

Actual results:
1. In the "Create Operator Subscription" page, the icon of the operator on the right of the "Select Operator Group" dropdown is streched to make the icon fit into a square.

Expected results:
1. The icon of the operator shouldn't be warped in any way on the "Create Operator Subscription" page.

Additional info:

Comment 1 Jeff Phillips 2019-01-30 13:14:52 UTC
PR: https://github.com/openshift/console/pull/1150

Comment 2 Fan Jia 2019-02-14 05:47:58 UTC
It is ok in env:
cv: 4.0.0-0.nightly-2019-02-13-204401
console : quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:65d45bc11133e47d739c729969241654813830bb315ad805e71e7a677a8e73e6
console commit :https://github.com/openshift/console/commit/e05b0365a496188c5cd35fc9efa51a153bb2ae95

Comment 5 errata-xmlrpc 2019-06-04 10:42:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.