Bug 166932 - Obtaining hostname information has inappropriate timeout value
Obtaining hostname information has inappropriate timeout value
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 166933 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-28 07:05 EDT by Wade Mealing
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 14:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2005-08-28 07:05:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When the machine that is being installed has a network configured, yet no DNS available, the machine will prompt you for a DNS server.  Even if this setting is left blank, anaconda still attempts to obtain dns and hostname information.  

This causes the anaconda to stall for about 3 minutes.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install, have a network setup, with DHCP not handing out DNS information.
2. The installer will get a DHCP address, but no DNS information

  

Actual Results:  Server waits for about 3 minutes, the installer has not hung, although it takes excessively long to obtain an address.

Expected Results:  One would expect this to time out in a shorter time period, if your DNS is supposed to be working and it cant get an address in less than a minute, you have larger problems to deal with.

Additional info:

RHEL 4 U1.
Comment 1 Wade Mealing 2005-08-28 07:08:24 EDT
This is a dupe of 166933.
Comment 2 Jeremy Katz 2005-08-29 14:40:06 EDT
*** Bug 166933 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2005-08-30 14:50:56 EDT
This is how long a gethostbyaddr() takes.  Not much that can really be done
about it.

Note You need to log in before you can comment on or make changes to this bug.