Bug 1669352 - Release geany 1.34 for RHEL 7/Centos 7
Summary: Release geany 1.34 for RHEL 7/Centos 7
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: geany
Version: epel7
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
: 1690201 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2019-01-25 01:58 UTC by agents
Modified: 2020-06-11 18:53 UTC (History)
5 users (show)

Fixed In Version: geany-1.36-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2020-06-11 18:53:49 UTC
Type: Bug

Attachments (Terms of Use)

Description agents 2019-01-25 01:58:03 UTC
Description of problem:

Is it possible to get geany 1.34 released for RHEL 7/Centos 7? The latest version available is 1.31 which was released in 2017.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 1 Dominic Hopf 2019-03-09 11:06:29 UTC
Can you check out if this works for you?


Unfortunately I have no enterprise machines around (at least none with graphical user interface) to test that myself. If it works I'd push it as an update.

Comment 2 agents 2019-03-10 20:51:05 UTC
Happy to. What is the best way to install this test release without damaging current install of geany? Also, could you compile the plugins so I can test them? There is a markdown plugin that has been missing for a few releases that I am in need of.

Thank you.

Comment 3 agents 2019-03-19 01:45:23 UTC
(In reply to agents from comment #2)
> Happy to. What is the best way to install this test release without damaging
> current install of geany? Also, could you compile the plugins so I can test
> them? There is a markdown plugin that has been missing for a few releases
> that I am in need of.
> Thank you.

Got it installed and running in docker with CentOS 7 as the host system, seems to work fine. Suggest it be released.

Also, could you compile the geany-plugins?

Thank you.

Comment 4 Dominic Hopf 2019-03-23 08:18:05 UTC
*** Bug 1690201 has been marked as a duplicate of this bug. ***

Comment 5 agents 2019-07-15 12:03:06 UTC
Any update on this? Would be great if this could be released.

Comment 6 agents 2019-08-10 00:40:52 UTC
Geany and Geany Plugins 1.35 have been released. Can the EPEL releases be updated to this latest version? It also seems 1.34 was never put into EPEL after I tested it?

Thank you.

Comment 7 agents 2019-09-29 01:10:39 UTC
I understand that Geany is now at version 1.36. Would it be possible to have EPEL updated with respect to Geany and Geany plugins?

Comment 8 Dominic Hopf 2020-04-08 20:37:07 UTC
Sorry for being a bit unresponsive in the past. I've just succesfully built Geany and Geany-Plugins for EPEL8, it will be pushed to testing soon: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-5392d2e45e
Do you still have need for builds on EPEL7?

Comment 9 agents 2020-04-09 16:59:49 UTC
Yes, please, that would be great. I have not been able to move it to the top of my list of things to do so your assistance would be greatly appreciated. The current version seems to be 1.36 - is that the version you built? Are you able to build all plugins, including the markdown one?

Comment 10 Dominic Hopf 2020-04-10 11:23:45 UTC
Yep, 1.36 is built for EPEL8 and available via updates-testing repositories in EPEL8. I just fixed another issue with installing geanygendoc (see #1754361) so you may wait another day before installing it.

Actually the plugins are only available on architectures x86_64 and ppc64le because there are some outstanding issues building the markdown plugin for aarch64 and s390x. But this is kind of specific and should not be an issue for you if you don't use the aarch64 and s390x architectures.

It will be a bit more effort for building stuff for EPEL7 as well, so this probably takes some time until I get finished everything for EPEL7. I will let you know right here in this place when there is news about it. (:

Comment 11 Fedora Update System 2020-05-24 17:44:46 UTC
FEDORA-EPEL-2020-3a85ca9e73 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3a85ca9e73

Comment 12 Dominic Hopf 2020-05-24 17:48:18 UTC
So finally I've made it to successfully build the Geany-Plugins, now we have an update: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3a85ca9e73
This of course will land in the epel-testing repositories first, you will be able to update this with a command similar to this:

yum -y update geany* --enablerepo=epel-testing

If everything works fine for you I appreciate any feedback and Karma on the link above.

Comment 13 agents 2020-05-25 01:14:45 UTC
Hm, just tried yum -y update geany* --enablerepo=epel-testing above but it said "no packages marked for update"?

Comment 14 Fedora Update System 2020-05-25 04:12:05 UTC
FEDORA-EPEL-2020-3a85ca9e73 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-3a85ca9e73

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 agents 2020-05-25 14:28:11 UTC
Now I was able to download and install but I miss the markdown plugin. Can that be updated as well? It is a critical plugin for me.

Also, would you be willing to publish your complete update instructions? I am a novice at compiling software for my own use but would like to try compiling geany.

Thank you!

Comment 16 Dominic Hopf 2020-05-25 20:57:39 UTC
As far as I can see the markdown plugin has been built as well: https://koji.fedoraproject.org/koji/buildinfo?buildID=1489882
It must be installable, probably you will have to add geany-plugins as well to the yum command:

yum -y update geany-* geany-plugins-* --enablerepo=epel-testing

Basically sources for RPM packages in Fedora are always available to everyone (this is an open source project, isn't it?):

* https://src.fedoraproject.org/rpms/geany
* https://src.fedoraproject.org/rpms/geany-plugins

There is no specific update instructions I have, additionally to these RPM sources, though. This was rather trial & error until it works.

Comment 17 agents 2020-05-25 23:00:00 UTC
Ah, it was because it had not been installed with the previous update - I think it was not available at that time. I ran yum install ... and it, and three other geany plugins, were installed.

However, I see to my disappointment it still does not handle markdown tables...

Comment 18 Dominic Hopf 2020-05-26 16:22:30 UTC
I'm not into the details of each plugin, unfortunately. If you have any plugin-specific concerns probably the upstream project is the better place to ask questions, or for features and bugs. You will find contact and support possibilities like mailing lists, bug trackers and chat on https://geany.org/ at the support menu at the top of the page. Information for the markdown plugin in general can also be found here: https://plugins.geany.org/markdown.html.

Comment 19 Fedora Update System 2020-06-11 18:53:49 UTC
geany-1.36-2.el7, geany-plugins-1.36-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.